Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 198259 - The scim systray icon in gnome-panel does not become transparent.
Summary: The scim systray icon in gnome-panel does not become transparent.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: scim
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jens Petersen
QA Contact:
URL:
Whiteboard:
: 202741 (view as bug list)
Depends On:
Blocks: FC6Target SCIM
TreeView+ depends on / blocked
 
Reported: 2006-07-10 17:49 UTC by Satoru SATOH
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 1.4.4-32.fc6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-10-02 16:21:08 UTC


Attachments (Terms of Use)
The patch to make scim systray icon transparent (deleted)
2006-07-10 17:49 UTC, Satoru SATOH
no flags Details | Diff
status_icon.patch (deleted)
2006-08-24 13:49 UTC, Jens Petersen
no flags Details | Diff

Description Satoru SATOH 2006-07-10 17:49:08 UTC
Description of problem: When making gnome-panel transparent, systray icons in
its notification area (e.g. NetworkManager's) reflect that configuration and
background color is transparent. However, scim systray icon does not become
transparent and colored gray.

Version-Release number of selected component (if applicable):
$ rpm -q scim scim-libs
scim-1.4.4-23
scim-libs-1.4.4-23

How reproducible: Always

Steps to Reproduce:
1. Login (GNOME session)
2. Make the top panel (gnome-panel) transparent.
  (1) Right click the top panel and open "Panel Properties" dialog
  (2) Click "Background" tab and select [Solid Color]
  (3) Slide the holizontal slider and set its transparency. 

  
Actual results:


Expected results:


Additional info:
I made a quick temporal fix originally came from NetworkManager.

In the future, it should use GTKStatusIcon, new widget from 2.10, I guess.

Comment 1 Satoru SATOH 2006-07-10 17:49:08 UTC
Created attachment 132188 [details]
The patch to make scim systray icon transparent

Comment 2 Satoru SATOH 2006-07-11 04:25:19 UTC
FYI. My patch looks submitted into upstream cvs.

[ 1520119 ] The scim systray icon in gnome-panel does not become transp....
https://sourceforge.net/tracker/?func=detail&atid=650539&aid=1520119&group_id=108454

Comment 3 Jens Petersen 2006-07-17 20:14:28 UTC
Thanks for the report and patch.

Perhaps I'm missing something but after applying the patch,
the scim systray icon is still not transparent for me.

Comment 4 Jens Petersen 2006-07-24 06:38:05 UTC
I checked that your code should definitely be in 1.4.4-24.

You think one of scim_panel_gtk-*.patch affects this?

Comment 5 Satoru SATOH 2006-07-25 01:36:42 UTC
I'm not sure about that but the recent changes in scim_panel_gtk.cpp causing this.
1.4.4-23 + my patch just works fine. 



Comment 6 Satoru SATOH 2006-07-25 01:53:28 UTC
> ... the recent changes in scim_panel_gtk.cpp causing this.
It's my feeling. I did not check it.

BTW, if scim-systray needs both normal menu and context menu, the code in
NetworkManager/gnome/applet/ should be helpful, I guess.

Comment 7 Jens Petersen 2006-07-25 07:03:04 UTC
Tagoh commented that it is probably due to changing the base systray
widget from the Gtk Button to an EventBox in scim_panel_gtk-icon-size-fixes.patch.
(That patch hasn't been submitted upstream yet btw.)

(Does the NetworkManager applet do the menus in a better way?)

Comment 8 Jens Petersen 2006-08-16 08:06:58 UTC
*** Bug 202741 has been marked as a duplicate of this bug. ***

Comment 9 Jens Petersen 2006-08-24 13:49:46 UTC
Created attachment 134811 [details]
status_icon.patch

For reference here is a rough patch that implements the tray icon using
GtkStatusIcon.	It seems to work well except the menu activation
is only for click not release.

Comment 10 Jens Petersen 2006-08-24 14:01:03 UTC
For now I will revert the tray icon to a GtkButton so that transparency works.
This has the unfortunately side effect that the icon has to be much smaller
unfortunately since the button restricts the available child size considerably
and the default gnome panel size is pretty small.

Fix should be in scim-1.4.4-32.fc6.

Comment 11 Satoru SATOH 2006-08-30 17:06:48 UTC
I confirmed it works as a workaround, so will close this.

But I don't think EventBox is the cause of this issue. Both gpm
(gnome-power-manager) and nm (NetworkManager) look using gtk_event_* but work
fine. I'll look 

Comment 12 Jens Petersen 2006-09-29 13:16:18 UTC
I am tempted re-revert to the EventBox, since I feel the size problem
is more serious than the transparency issue.

I think the difference may be since g-p-m and NM are gnome-panel applets
whereas the scim icon sits in the notification tray.

Comment 13 Jens Petersen 2006-10-02 16:20:16 UTC
I reduced the icon size of the systray button to 12 now scim-1.4.4.fc6.


Note You need to log in before you can comment on or make changes to this bug.