Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 198211 - ldd -r reports undefined symbols
Summary: ldd -r reports undefined symbols
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-pilot
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
: 237492 (view as bug list)
Depends On:
Blocks: FC7Target ldd-r-kh
TreeView+ depends on / blocked
 
Reported: 2006-07-10 14:30 UTC by Karsten Hopp
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: gnome-pilot-2.0.15-8.fc7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-24 14:50:42 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 431145 None None None Never

Description Karsten Hopp 2006-07-10 14:30:06 UTC
Note: ldd can't handle dlopen'ed dependent libraries and these unresolved symbols
might be resolved by those. But this needs to be checked.
Reproducer: rpm -ql <packagename>| grep lib.*so | xargs ldd -r


gnome-pilot-devel-2.0.13-13
undefined symbol: xmlFree       (/usr/lib/libgpilotdcm.so)
undefined symbol: g_str_hash    (/usr/lib/libgpilotdcm.so)
undefined symbol: g_str_equal   (/usr/lib/libgpilotdcm.so)
undefined symbol: g_free        (/usr/lib/libgpilotdcm.so)
undefined symbol: g_dir_close   (/usr/lib/libgpilotdcm.so)
undefined symbol: g_strdup_printf       (/usr/lib/libgpilotdcm.so)
undefined symbol: g_strcasecmp  (/usr/lib/libgpilotdcm.so)
undefined symbol: gtk_object_get_type   (/usr/lib/libgpilotdcm.so)
undefined symbol: gnome_config_clean_key_       (/usr/lib/libgpilotdcm.so)
undefined symbol: gnome_config_pop_prefix       (/usr/lib/libgpilotdcm.so)
...

Comment 1 Christopher Aillon 2007-04-17 19:22:39 UTC
Is this still an issue?  We should try and resolve this for f7...

Comment 2 Matthias Clasen 2007-04-17 22:56:29 UTC
yes, still happening. libgpilotdcm.so nees to be linked against (at least)
libxml, libgnome and glib, but it isn't.

Comment 3 Matthias Clasen 2007-04-18 05:06:00 UTC
Looks like the Makefile only adds the libs to the binaries, not to the libraries.

Comment 4 Matthew Barnes 2007-04-18 21:30:36 UTC
Mostly fixed in gnome-pilot-2.0.15-5.fc7.

There's still a few outliers:

   $ rpm -ql gnome-pilot-devel | grep lib.*so | xargs ldd -r | grep missing
   undefined symbol: gnome_pilot_conduit_sync_type_int_to_str      
   (/usr/lib/libgpilotdcm.so)
   undefined symbol: gnome_pilot_conduit_sync_type_str_to_int      
   (/usr/lib/libgpilotdcm.so)
   undefined symbol: gnome_pilot_conduit_set_name  (/usr/lib/libgpilotdcm.so)

but I think these can be a build order issue as mentioned in the README:

   * NOTE: Currently theres a buildorder bug between libgpilotdCM and
   * gpilotd. If you get a compiletime error in libgpilotdCM that file
   * "gpilotd/gnome-pilot-conduit.h" is missing, do a make -k and then
   * make again.

Closing this bug and forwarding the remaining issue upstream.

Comment 5 Matthew Barnes 2007-04-18 21:39:59 UTC
s|can be a build order issue|can be attributed to a build order issue|

Upstream bug: http://bugzilla.gnome.org/show_bug.cgi?id=431145

Comment 6 Matthew Barnes 2007-04-23 19:01:34 UTC
Reopening since upstream has a fix for the remaining issue:
http://bugzilla.gnome.org/show_bug.cgi?id=431145#c6

Comment 7 Matthew Barnes 2007-04-23 19:03:57 UTC
*** Bug 237492 has been marked as a duplicate of this bug. ***

Comment 8 Matthew Barnes 2007-04-23 22:10:28 UTC
Aw nuts.  Even with the upstream fix applied, we're still missing one:

   $ rpm -ql gnome-pilot-devel | grep lib.*so | xargs ldd -r > /dev/null
   undefined symbol: gnome_pilot_conduit_set_name  (/usr/lib/libgpilotdcm.so)

Applied the current fix to gnome-pilot-2.0.15-7.fc7.

Also reopened the upstream bug to get that last symbol taken care of.

Comment 9 Matthew Barnes 2007-04-24 14:50:42 UTC
Upstream has taken care of the last symbol, and I've backported the fix.

Fixed (for good) in gnome-pilot-2.0.15-8.fc7.


Note You need to log in before you can comment on or make changes to this bug.