Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1981 - horrible nfs performance on solaris nfs mounts
Summary: horrible nfs performance on solaris nfs mounts
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: nfs-server
Version: 5.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
: 3806 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-04-04 13:15 UTC by Karl Berry
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-15 04:12:59 UTC


Attachments (Terms of Use)

Description Karl Berry 1999-04-04 13:15:44 UTC
Actually this isn't NFS server, it's NFS client.
When I mount a Solaris filesystem, performance is horrible.
For instance, if I'm editing a 2MB file, every save (or
auto-save) has a significant delay, perhaps 10-15 seconds.
This does not happen with solaris-solaris nfs (or
linux-linux for that matter).

I've set rsize and wsize to 4096; with 8192, I experienced
hangs logging in to the system (the home directories are the
ones on the nfs mount).

The filesystem is on a Solaris machine in the first place
because the linux nfs server crashes and corrupts at will,
per my earlier message.

Any clues would be appreciated.  An improved NFS
implementation in the next release would be even more
appreciated :).

Thanks.

Comment 1 Jay Turner 1999-06-29 18:40:59 UTC
*** Bug 3806 has been marked as a duplicate of this bug. ***

When my Linux box is an NFS client of a Solaris 2.6 server,
NFS write performance is very very slow.  I have fiddled
with I/O block sizes, but the problem remains.

Comment 2 Michael K. Johnson 1999-09-25 17:05:59 UTC
There exists a patch to Solaris, I'm told, to fix this.  I don't
have details on where to get the patch.


Note You need to log in before you can comment on or make changes to this bug.