Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 197918 - no more info.capabilities={'printer'}; breaks auto print queues
Summary: no more info.capabilities={'printer'}; breaks auto print queues
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: hal
Version: rawhide
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: John (J5) Palmieri
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-07-07 12:02 UTC by Tim Waugh
Modified: 2013-03-13 04:50 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-07-27 17:28:55 UTC


Attachments (Terms of Use)

Description Tim Waugh 2006-07-07 12:02:28 UTC
Description of problem:
Automatic local print queues is not working because our fdi rule never matches:

<match key="info.capabilities" contains="printer">

I'm trying this with a USB-connected HP DeskJet 990Cxi.

Version-Release number of selected component (if applicable):
kernel-2.6.17-1.2356.fc6
hal-0.5.7-12
udev-095-2

How reproducible:
100%

Steps to Reproduce:
1. Boot with printer on
2. Observe that no queue is added
3. lshal and look for its entry

I'm pretty sure this was working right a couple of weeks ago.

Comment 1 John (J5) Palmieri 2006-07-07 14:01:10 UTC
Is it just that printer or all printer?

Comment 2 Tim Waugh 2006-07-07 14:15:16 UTC
Haven't yet tried with the only other USB printer I have access to; will have to
wait until later today.

Comment 3 Matthias Clasen 2006-07-27 17:08:35 UTC
John, didn't you have a fix for this ?

Comment 4 John (J5) Palmieri 2006-07-27 17:28:55 UTC
Fixed


Note You need to log in before you can comment on or make changes to this bug.