Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 196683 - Crash on installing: Unable to synchronise. Dump enclosed.
Summary: Crash on installing: Unable to synchronise. Dump enclosed.
Keywords:
Status: CLOSED DUPLICATE of bug 160693
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-06-26 14:17 UTC by Alan Howlett
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-07-21 19:49:20 UTC


Attachments (Terms of Use)
Anaconda Dump (deleted)
2006-06-26 14:17 UTC, Alan Howlett
no flags Details

Description Alan Howlett 2006-06-26 14:17:41 UTC
Description of problem:
I was trying to so a clean install onto an old Brio PC, with just FTP, HTTP
servers and a few accessories. Anaconda reported that there was a problem with
the core knowing about changes to the disks. I tried to get it to retry this,
but instead it failed.

Version-Release number of selected component (if applicable):
FC4

How reproducible:
I don't know if it's reproducible, but I have attached a dump that might
sidestep the need to include steps to reproduce.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 1137, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 244, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 873, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 174, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 242, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 579, in turnOnFilesystems
    diskset.savePartitions ()
  File "/usr/lib/anaconda/partedUtils.py", line 726, in savePartitions
    disk.commit()
error: Warning: The kernel was unable to re-read the partition table on /dev/hdb
(Device or resource busy).  This means Linux won't know anything nothing about
the modifications you made until you reboot.  You should reboot your computer
before doing anything with /dev/hdb.

Local variables in innermost frame:
self: <partedUtils.DiskSet instance at 0xb7cb8c2c>
disk: <PedDisk object at 0xb7ee4fb0>


Package Group selection status:
ISO8859-9 Support: 0
Office/Productivity: 0
Compatibility Arch Development Support: 0
Engineering and Scientific: 0
MySQL Database: 0
Development Libraries: 0
Malay Support: 0
Portuguese Support: 0
Editors: 1
System Tools: 1
Japanese Support: 0
Hungarian Support: 0
Punjabi Support: 0
British Support: 0
Korean Support: 0
GNOME Software Development: 0
German Support: 0
Gaelic Support: 0
Faeroese Support: 0
Swedish Support: 0
Server: 0
Russian Support: 0
Text-based Internet: 1
Serbian Support: 0
KDE: 0
Gujarati Support: 0
Catalan Support: 0
Lithuanian Support: 0
X Software Development: 0
Workstation Common: 0
Legacy Network Server: 0
x86 Compatibility Arch Support: 0
GNOME Desktop Environment: 1
Dialup Networking Support: 1
Turkish Support: 0
Arabic Support: 0
Basque Support: 0
Everything: 0
Core: 0
Authoring and Publishing: 0
Irish Support: 0
Italian Support: 0
Slovak Support: 0
Base: 1
Slovenian Support: 0
FTP Server: 1
Java: 0
Network Servers: 0
Kannada Support: 0
GNOME: 0
Breton Support: 0
Romanian Support: 0
Games and Entertainment: 0
Greek Support: 0
Compatibility Arch Support: 0
Zulu Support: 0
Miscellaneous Included Packages: 0
Danish Support: 0
Afrikaans Support: 0
Legacy Software Development: 0
Brazilian Portuguese Support: 0
Cyrillic Support: 0
Welsh Support: 0
Thai Support: 0
Java Development: 0
Emacs: 0
Tamil Support: 0
Legacy Software Support: 0
Windows File Server: 0
X Window System: 1
Chinese Support: 0
Graphics: 0
Web Server: 1
Ruby: 0
Czech Support: 0
Bulgarian Support: 0
Indonesian Support: 0
Eclipse: 0
Galician Support: 0
Dutch Support: 0
Printing Support: 0
KDE Software Development: 0
Icelandic Support: 0
Ukrainian Support: 0
Assamese Support: 0
KDE (K Desktop Environment): 1
Bengali Support: 0
Mail Server: 0
Spanish Support: 0
Hebrew Support: 0
Estonian Support: 0
French Support: 0
Server Configuration Tools: 1
Croatian Support: 0
Language Support: 0
PostgreSQL Database: 0
Finnish Support: 0
Norwegian Support: 0
Administration Tools: 1
Polish Support: 0
News Server: 0
Hindi Support: 0
DNS Name Server: 0
Development Tools: 0
Sound and Video: 0
Graphical Internet: 1
ISO8859-2 Support: 0

Comment 1 Alan Howlett 2006-06-26 14:17:41 UTC
Created attachment 131542 [details]
Anaconda Dump

Comment 2 Chris Lumens 2006-07-21 19:49:20 UTC

*** This bug has been marked as a duplicate of 160693 ***


Note You need to log in before you can comment on or make changes to this bug.