Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 196344 - Update libnotify to 0.4.2 and fix devel requirements
Summary: Update libnotify to 0.4.2 and fix devel requirements
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libnotify
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: John (J5) Palmieri
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-06-22 17:33 UTC by Matthias Saou
Modified: 2013-03-13 04:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-07-21 18:54:31 UTC


Attachments (Terms of Use)

Description Matthias Saou 2006-06-22 17:33:17 UTC
Hi, while trying to rebuild the latest bmpx on Fedora Core development, it
failed because it requires libnotify >= 0.4.2 and Rawhide currently "only" has
0.4.0.

Would it be possible to update the package to 0.4.2? Thanks!

Comment 1 Matthias Saou 2006-06-26 12:00:27 UTC

*** This bug has been marked as a duplicate of 191731 ***

Comment 2 Matthias Saou 2006-07-21 08:36:39 UTC
Please update libnotify to 0.4.2 ASAP. See the patch from bug #191731 if you
want, but it's pretty straightforward.

Comment 3 Matthias Saou 2006-07-21 11:54:13 UTC
Another problem in the current package worth mentioning :

"Package 'dbus-glib-1', required by 'libnotify', not found"

From the libnotify.pc file :

Requires: gtk+-2.0 >= 2.2.2, glib-2.0 >= 2.2.2, dbus-1 >= 0.36, dbus-glib-1 >= 0.36

This would have been picked up automatically if rpm had been recent enough, but
for the time being, requirements should be manually added to the libnotify-devel
package. At least dbus-glib-devel and possibly dbus-devel (*) since gtk2-devel
is already listed and requires glib2-devel.

(*) Current dbus-glib-devel doesn't require dbus-devel, this seems like a bug
since its pkgconfig file indicates it requires it.

Comment 4 John (J5) Palmieri 2006-07-21 18:54:31 UTC
Building in rawhide now.  Thanks.


Note You need to log in before you can comment on or make changes to this bug.