Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 195982 - Cannot use control-alt-delete to reboot after installer abnormal exit
Summary: Cannot use control-alt-delete to reboot after installer abnormal exit
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 5
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-06-20 05:02 UTC by Emmanuel Galanos
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-06-27 19:48:47 UTC


Attachments (Terms of Use)

Description Emmanuel Galanos 2006-06-20 05:02:23 UTC
Description of problem:
I terminated the X server with Ctrl-Alt-Backspace due to bug #186689. Anaconda
drops to the console and terminates/unmounts everything and prints that it is
okay to reboot the system. However Ctrl-Alt-Delete does not work and the machine
needs to be power cycled. Not fun if the machine is being accessed via a kvm.

Version-Release number of selected component (if applicable):
FC 5 release installer.

How reproducible:
100%

Steps to Reproduce:
1. Terminate X server (or otherwise cause Anaconda to exit abnormally)
2. Try to reboot with Ctrl-Alt-Delete.

Actual results:
No reboot.

Expected results:
Reboot.

Comment 1 Jeremy Katz 2006-06-20 14:47:13 UTC
This works fine for me here -- is tty switching still working?  Also, you can
try sysrq as another option.

Comment 2 Emmanuel Galanos 2006-06-23 10:57:26 UTC
TTY switching still works. Sysrq also works.

The problem appears to be a kernel bug with ignoring right alt. Right alt also
is ignore in Anaconda.

left control-left alt-delete works
right control-left alt-delete works
right control-right alt-delete does NOT work (in Linux. Works in BIOS)
left control-right alt-delete does NOT work (in Linux. Works in BIOS)


Comment 3 Chris Lumens 2006-06-27 19:48:47 UTC
Right control and right alt are different keys from the left ones, which means
they have different keycodes.  Linux doesn't trap those the way it does trap the
left ctrl and alt to cause a reboot.


Note You need to log in before you can comment on or make changes to this bug.