Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 194023 - Unrecoverable error: rangecheck in get
Summary: Unrecoverable error: rangecheck in get
Alias: None
Product: Fedora
Classification: Fedora
Component: ghostscript
Version: 5
Hardware: i386
OS: Linux
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Mike McLean
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
Reported: 2006-06-05 03:25 UTC by Bob T.
Modified: 2008-08-02 23:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2006-06-07 11:09:23 UTC

Attachments (Terms of Use)

Description Bob T. 2006-06-05 03:25:48 UTC
Description of problem:  Most ghostscript commands fail with range check errors.

Version-Release number of selected component (if applicable):  8.15.2-1.1

How reproducible: Every Postscript file I've tried.

Steps to Reproduce:
1.ps2pdf or gv
Actual results:

Unrecoverable error: rangecheck in get
Operand stack:
      hrsyr.gsf    0

Expected results:
conversion to pdf or display

Additional info: The Postscript files I've tried work fine on ghostscript-7.07.

Comment 1 Bob T. 2006-06-05 03:27:16 UTC
Correction:  the product version number should be FC5 rather than FC4.

Comment 2 Bob T. 2006-06-05 11:21:02 UTC
Even gs by itself at the command line fails:

 % gs
 ESP Ghostscript 815.02 (2006-04-19)
 Copyright (C) 2004 artofcode LLC, Benicia, CA.  All rights reserved.
 This software comes with NO WARRANTY: see the file PUBLIC for details.
 CRIT: rangecheck in get
 Operand stack:
      hrsyr.gsf    0

However gs -h produces the usual output. The search path is as follows:

Search path:
   . : /usr/share/ghostscript/8.15/lib :
   /usr/share/ghostscript/8.15/Resource : /usr/share/ghostscript/fonts :
   /usr/share/fonts/default/ghostscript : /usr/share/fonts/default/Type1 :
   /usr/share/fonts/default/amspsfnt/pfb :
   /usr/share/fonts/default/cmpsfont/pfb : /usr/share/fonts/japanese :

Comment 3 Tim Waugh 2006-06-05 11:34:27 UTC
What does 'rpm -q ghostscript-fonts' say, and also 'rpm -V ghostscript-fonts'?

Comment 4 Bob T. 2006-06-05 12:40:36 UTC
% rpm -q ghostscript-fonts

% rpm -V ghostscript-fonts

(no output) 

According to locate, /usr/share/fonts/default/ghostscript/hrsyr.gsf
is the only hrsyr.gsf on the system. 

I have the same issue on a second recently-upgraded system, but not on a third.

Comment 5 Tim Waugh 2006-06-05 12:57:57 UTC
What about 'rpm -V ghostscript'?  It seems like this file is only referenced in

Comment 6 Bob T. 2006-06-05 13:17:28 UTC
% rpm -V ghostscript produces no output.  And I've rebuilt and re-installed
ghostscript from the src rpm with the same result.  I've also tried commenting
out the line with hrsyr.gsf in Fontmap.GS with no apparent effect.

Comment 7 Bob T. 2006-06-05 20:19:57 UTC
>It seems like this file [hrsyr.gsf] is only referenced in

There's a Fontmap in /usr/share/fonts/default/ghostscript that references hrsyr.gsf:

/                                        (hrsyr.gsf)

though without the FontName. If I add Hershey-Symbol as the FontName, the error
message changes to
  CRIT: rangecheck in get
  Operand stack:
      hrscso.gsf    0

that is, to the font referenced in the last line in the Fontmap *without* a
FontName. And so on.  Does every font in a Fontmap have to have a FontName?  
How does this Fontmap get generated?

Comment 8 Bob T. 2006-06-06 20:56:58 UTC
Does anyone have any suggestions on what I'm supposed to do with two Linux boxes
that don't have a working gs? Can rangechecks be disabled?

Comment 9 Tim Waugh 2006-06-07 10:02:53 UTC
Nothing in ghostscript creates that file that I am aware of.  I don't have a
Fontmap file there.

What does 'rpm -qf' on that file say?

Comment 10 Bob T. 2006-06-07 11:09:23 UTC
That Fontmap was created by the type1inst script.  When that Fontmap is removed,
ghostscript works.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.