Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 193830 - freeradius-mysql missing components (rlm_sql_mysql - missing dependent libraries)
Summary: freeradius-mysql missing components (rlm_sql_mysql - missing dependent librar...
Keywords:
Status: CLOSED DUPLICATE of bug 161907
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: freeradius
Version: 3.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-06-01 21:52 UTC by David Herselman
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-06-07 09:56:44 UTC
Target Upstream Version:


Attachments (Terms of Use)
Full output from '/usr/sbin/radiusd -X' (deleted)
2006-06-01 21:52 UTC, David Herselman
no flags Details
Radius Startup information (strace -f -o log radiusd -X) (deleted)
2006-06-06 17:08 UTC, David Herselman
no flags Details
Strace output (strace -f -o log radiusd -X) (deleted)
2006-06-06 17:22 UTC, David Herselman
no flags Details

Description David Herselman 2006-06-01 21:52:02 UTC
Description of problem:
  There appear to be missing components or missing dependencies in the
  freeradius-mysql package which is preventing it from launching

Version-Release number of selected component (if applicable):
  freeradius-mysql-1.0.1-2.RHEL3.2
  freeradius-1.0.1-2.RHEL3.2

How reproducible:
  Always

Steps to Reproduce:
1. rpm -ivh freeradius-1.0.1-2.RHEL3.2
2. rpm -ivh freeradius-mysql-1.0.1-2.RHEL3.2
3. edit /etc/raddb/radiusd.conf and enable SQL components
4. Then launch manually with '/usr/sbin/radiusd -X'
  
Actual results:
  <full log attached>
  rlm_sql (sql): Could not link driver rlm_sql_mysql: file not found
  rlm_sql (sql): Make sure it (and all its dependent libraries!) are in the
  search path of your system's ld.
  radiusd.conf[14]: sql: Module instantiation failed.

Expected results:
  Should communicate with MySQL

Additional info:
  Works fine on a RHEL4 server (installed RHEL4's freeradius rpms and copied
  content of /etc/raddb to RHEL4 server).

  Possible NB: The machine has no development libraries/tools, it's supposed
               to be a pure MySQL/Apache/FreeRadius box.

Comment 1 David Herselman 2006-06-01 21:52:02 UTC
Created attachment 130376 [details]
Full output from '/usr/sbin/radiusd -X'

Comment 2 Thomas Woerner 2006-06-06 15:26:11 UTC
Please "strace -f -o log radiusd -X"

Comment 3 David Herselman 2006-06-06 17:08:47 UTC
Created attachment 130622 [details]
Radius Startup information (strace -f -o log radiusd -X)

Comment 4 David Herselman 2006-06-06 17:10:18 UTC
Attached output from 'strace -f -o log radiusd -X' but it doesn't look much
different from original output logged without running strace. The system this
is running on does not have any development tools on it, would this create a 
problem?

Comment 5 David Herselman 2006-06-06 17:17:30 UTC
This Bugzilla listing appears to match my problem exactly, except that I've
not re-compiled original packages:

Bugzilla ID:      161907
Bugzilla Summary: Could not link driver rlm_sql_mysql: file not found
Link:             https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=161907

Comment 6 David Herselman 2006-06-06 17:22:10 UTC
Uargh, herewith the information you wanted from 'strace' (full log attached):

30873 open("/usr/lib/rlm_sql_mysql.la", O_RDONLY) = -1 ENOENT (No such file or 
directory)
30873 open("/lib/rlm_sql_mysql.la", O_RDONLY) = -1 ENOENT (No such file or 
directory)
30873 open("/usr/lib/rlm_sql_mysql.la", O_RDONLY) = -1 ENOENT (No such file or 
directory)
30873 open("rlm_sql_mysql.la", O_RDONLY) = -1 EACCES (Permission denied)


Comment 7 David Herselman 2006-06-06 17:22:59 UTC
Created attachment 130623 [details]
Strace output (strace -f -o log radiusd -X)

Comment 8 David Herselman 2006-06-06 17:23:50 UTC
Comment on attachment 130622 [details]
Radius Startup information (strace -f -o log radiusd -X)

Attached wrong information

Comment 9 Thomas Woerner 2006-06-07 09:56:44 UTC

*** This bug has been marked as a duplicate of 161907 ***


Note You need to log in before you can comment on or make changes to this bug.