Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 193475 - [patch] packaged symbolic link to an unpackaged file
Summary: [patch] packaged symbolic link to an unpackaged file
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: docbook-dtds
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ondrej Vasik
QA Contact:
URL:
Whiteboard:
: 59133 130602 (view as bug list)
Depends On:
Blocks: FC7Target
TreeView+ depends on / blocked
 
Reported: 2006-05-29 13:06 UTC by Robert Scheck
Modified: 2013-01-10 03:52 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-06-20 13:53:04 UTC


Attachments (Terms of Use)
Patch for docbook-dtds spec file resolving this bug report (deleted)
2006-10-14 10:36 UTC, Robert Scheck
no flags Details | Diff

Description Robert Scheck 2006-05-29 13:06:35 UTC
Description of problem:
> ls -l /etc/sgml/sgml-docbook.cat /etc/sgml/xml-docbook.cat
lrwxrwxrwx 1 root root 27  7. Mar 00:25 /etc/sgml/sgml-docbook.cat -> sgml-
docbook-4.4-1.0-30.cat
lrwxrwxrwx 1 root root 26  7. Mar 00:25 /etc/sgml/xml-docbook.cat -> xml-
docbook-4.4-1.0-30.cat
>

> rpm -qf /etc/sgml/sgml-docbook.cat /etc/sgml/xml-docbook.cat
docbook-dtds-1.0-30.noarch
docbook-dtds-1.0-30.noarch
>

> ls -l /etc/sgml/sgml-docbook-4.4-1.0-30.cat /etc/sgml/xml-docbook-4.4-1.0-30.
cat
-rw-r--r-- 1 root root 124 Mar  7 00:25 /etc/sgml/sgml-docbook-4.4-1.0-30.cat
-rw-r--r-- 1 root root 123 Mar  7 00:25 /etc/sgml/xml-docbook-4.4-1.0-30.cat
>

> rpm -qf /etc/sgml/sgml-docbook-4.4-1.0-30.cat /etc/sgml/xml-docbook-4.4-1.0-
30.cat
file /etc/sgml/sgml-docbook-4.4-1.0-30.cat is not owned by any package
file /etc/sgml/xml-docbook-4.4-1.0-30.cat is not owned by any package
>

Version-Release number of selected component (if applicable):
docbook-dtds-1.0-30

How reproducible:
Everytime, see above.

Actual results:
There are packaged symbolic links in docbook-dts pointing to unpackaged files.

Expected results:
Rest of the files also packaged ;-)

Additional info:
Currently, dangling symbolic links are not detected at runtime by rpm - but the 
next generation of rpm is able to (whenever it reaches Rawhide). Nevertheless, 
all files should be packaged to be sane.

I would suggest to %ghost the files, which are currently unpackaged.

This shouldn't hurt (as far as tested on my devel system here) and maybe, the
rm -f /etc/sgml/{x,sg}ml-docbook-?.?-%{version}-%{release}.cat in %postun could 
also be removed (untested, yet).

Comment 1 Robert Scheck 2006-09-23 17:27:45 UTC
Tim, ping?

Comment 2 Robert Scheck 2006-10-14 10:17:02 UTC
Anybody alive? Can we please %ghost the unpackaged files in /etc/sgml/?

Comment 3 Robert Scheck 2006-10-14 10:36:28 UTC
Created attachment 138498 [details]
Patch for docbook-dtds spec file resolving this bug report

Comment 4 Robert Scheck 2006-12-19 23:05:29 UTC
Common, please :)

Comment 5 Ondrej Vasik 2007-05-21 07:57:46 UTC
*** Bug 130602 has been marked as a duplicate of this bug. ***

Comment 6 Ondrej Vasik 2007-05-21 13:25:17 UTC
*** Bug 59133 has been marked as a duplicate of this bug. ***

Comment 7 Ondrej Vasik 2007-06-20 13:53:04 UTC
Files touched and ghosted, checked Tim Waugh's comment about 
Failed to removed entry from /etc/sgml/sgml-docbook-3.0-1.0-4.cat
during rpm -Fvh ./RPMS/noarch/docbook-dtds-1.0-5.noarch.rpm in #59133, this
thing is ok with this solution, so I think we can use it.

Closing RAWHIDE, fixed in devel branch.


Note You need to log in before you can comment on or make changes to this bug.