Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 193431 - Nested sessions in GNOME (with different user) don't carry the same Keyboard map
Summary: Nested sessions in GNOME (with different user) don't carry the same Keyboard map
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 5
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC6Target FC5Update
TreeView+ depends on / blocked
 
Reported: 2006-05-28 06:36 UTC by Gian Paolo Mureddu
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-09-29 01:12:29 UTC


Attachments (Terms of Use)
gizipped output of xdpyinfo command (deleted)
2006-05-31 07:50 UTC, Gian Paolo Mureddu
no flags Details

Description Gian Paolo Mureddu 2006-05-28 06:36:21 UTC
Description of problem:
When started a session in a nested environment (for instance from whithin
gdmXnestchooser) as a different user, the keyboard map will not be preserved.
Not only this, but trying to execute the preferences->keyboard utility is
useless. The application works (sort of) as I can open it, but I can't set any
other keyboard map, when trying to add a new one, the selection will simply be
empty, the same goes for the type of keyboard.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xnest.x86_64 1.0.1-9.fc5.1.1

How reproducible:
Always

Steps to Reproduce:
1. Open up a session in either GNOME or KDE, make sure to have more than one
user account in the system.
2. Start gdmXnestchooser, login as a differnt user.
3. When you open preferences->keyboard, the program will only list the US
keyboard layout set as the default, and the program will be unable to change it
to any other map.
  
Actual results:
The keyboard is set to the US keyboard map by default, and the map can't be
changed for the nested session.

Expected results:
To have the same keybaord map as either defined as the default for X11 or for
the system. And to be able to change the keyboard map.

Additional info:

Comment 1 Mike A. Harris 2006-05-30 17:49:36 UTC
Can you attach the output of "xdpyinfo" running inside Xnest?  I have a
suspicion that Xnest does not have XKB support compiled into it.  This
is a problem that we recently fixed in RHEL.

Funny thing is, Xnest hasn't had XKB support since 2001 because of a
change introduced in XFree86 to disable hardware-only extensions.  If
current Xorg still has this problem, we'll need to update it as well.

TIA

Comment 2 Gian Paolo Mureddu 2006-05-31 07:50:35 UTC
Created attachment 130257 [details]
gizipped output of xdpyinfo command

Output from xdpyinfo to determine whether or not XKB support is compiled in or
not.

Comment 3 Mike A. Harris 2006-06-03 00:54:14 UTC
number of extensions:    22
    BIG-REQUESTS
    DAMAGE
    DEC-XTRAP
    DOUBLE-BUFFER
    Extended-Visual-Information
    GLX
    LBX
    MIT-SCREEN-SAVER
    MIT-SUNDRY-NONSTANDARD
    RECORD
    SECURITY
    SGI-GLX
    SHAPE
    SYNC
    TOG-CUP
    X-Resource
    XC-APPGROUP
    XC-MISC
    XFIXES
    XFree86-Bigfont
    XTEST
    XVideo


As suspected, the XKEYBOARD extension is absent.

Comment 4 Matthias Clasen 2006-07-06 21:58:48 UTC
Add to FC6Destop tracker

Comment 5 Søren Sandmann Pedersen 2006-09-29 01:12:29 UTC
This should be fixed in rawhide. (Please reopen if it isn't).


Note You need to log in before you can comment on or make changes to this bug.