Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 193276 - dri module crashes X on PoweEdge 1850 with Radeon 7000 video
Summary: dri module crashes X on PoweEdge 1850 with Radeon 7000 video
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 5
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks: FC6Target FC6Desktop
TreeView+ depends on / blocked
 
Reported: 2006-05-26 18:52 UTC by Leon Flaks
Modified: 2008-08-02 23:40 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-07-25 06:19:21 UTC


Attachments (Terms of Use)

Description Leon Flaks 2006-05-26 18:52:07 UTC
Description of problem:
X would not start on FC5. Fresh installation. Applying all the updates
did not improve situation. System boots up, goes in the black screen. It is
possible to login remotely. CPU runs X at around 100%.
Commenting out dri module in X ( Load "dri") solves the problem
However every time system-config-display is run, this line is added again and
needs to be commented out again

Version-Release number of selected component (if applicable):
1.0.1-2

How reproducible:

Alwaus
Steps to Reproduce:
1.Install the system
2.Upply all updates (optional)
3.Boot into runlevel 5.
  
Actual results:
Black screen, CPU runs at ~100%

Expected results:
Running X 

Additional info:

It looks very similar to other reports on different hardware/software combinations

Comment 1 Scott Schmit 2006-06-25 05:02:29 UTC
I also see the bug since I updated the kernel to kernel-2.6.17-1.2139_FC5 from
kernel-2.6.16-1.2133_FC5.

In my older kernel, I get the following from /var/log/messages:
Jun 25 00:54:17 elminster kernel: [drm] Initialized drm 1.0.1 20051102
Jun 25 00:54:17 elminster kernel: ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 16
(level, low) -> IRQ 16
Jun 25 00:54:17 elminster kernel: Avoiding DRI on Radeon R300+. Use
'allow_r300=1' module option to override
Jun 25 00:54:17 elminster kernel: DRM: Fill_in_dev failed.

In the new kernel, I see the following:
Jun 25 00:52:42 elminster kernel: [drm] Initialized drm 1.0.1 20051102
Jun 25 00:52:42 elminster kernel: ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 16
(level, low) -> IRQ 169
Jun 25 00:52:42 elminster kernel: [drm] Initialized radeon 1.24.0 20060225 on
minor 0

It then stops because the machine crashed (as far as I can tell--I can't kill X,
and I can't switch to a virtual console. Hitting the power button doesn't appear
to initiate a shutdown, but I haven't been terribly patient.)

I have a Dell Inspiron 6000. Video card: "ATI Technologies Inc M22 [Radeon
Mobility M300]" according to hwbrowser.

I haven't tried disabling DRI in xorg.conf, but it looks likely to "fix" the bug
given the above. I'll post another comment if it doesn't.

Comment 2 Mike A. Harris 2006-06-27 15:00:41 UTC
DRI is unsupported in FC5 on R300 and newer hardware.  You must comment out
the Load "dri" option if you have a kernel installed which provides the
r300 DRI module, or the module will load and will prevent the X server
from working properly.

It was my understanding that we removed R300 support from our kernel for
FC5, in which case the Load "dri" line should not do anything.

davej:  Has this changed at all?

Comment 3 Matthias Clasen 2006-07-06 21:55:51 UTC
Add to FC6Destop tracker

Comment 4 Mike A. Harris 2006-07-25 06:19:21 UTC
R300 support is provided in Fedora development now...


Note You need to log in before you can comment on or make changes to this bug.