Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 193088 - net-snmp (snmp v2) 64bit counters not working
Summary: net-snmp (snmp v2) 64bit counters not working
Keywords:
Status: CLOSED DUPLICATE of bug 158630
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: net-snmp
Version: 4.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Radek Vokal
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-25 05:49 UTC by David Ash
Modified: 2008-08-02 23:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-07-20 05:30:04 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description David Ash 2006-05-25 05:49:25 UTC
Description of problem:
Using snmp with cacti on gigabit network using 64bit counters doesn't graph
correctly.  Tried using the original RHEL4 U0 version and upgrading to the
latest net-snmp-5.1.2-11 but still failing.  Works successfully when compiling
netsnmp with:
--enable-mfd-rewrites.  I can't find this anywhere in net-snmp SPEC file or
source however so not sure what it does.

Version-Release number of selected component (if applicable):
net-snmp-5.1.2-11 (as well as original U0 version)

How reproducible:
net-snmp with cacti

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Graphs incorrectly without recompile, but graphs correctly when recompiled with
--enable-mfd-rewrites.

Expected results:
Not have to recompile.

Additional info:
Not sure if it is a bug as I've heard people using snmp v2 with mrtg but need
confirmation that "--enable-mfd-rewrites" isn't something missing in redhat
release of net-snmp.

Comment 1 Radek Vokal 2006-05-25 09:15:09 UTC
Are you sure that --enable-mfd-rewrites is in net-snmp-5.1.2? I thought it was
added later, in net-snmp-5.2.x and above.

Comment 2 David Ash 2006-07-20 05:30:04 UTC
Yes your right.  This bug looks to be a duplicate of 158630

*** This bug has been marked as a duplicate of 158630 ***


Note You need to log in before you can comment on or make changes to this bug.