Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 192805 - No usb printing after update
Summary: No usb printing after update
Alias: None
Product: Fedora
Classification: Fedora
Component: cups
Version: 5
Hardware: i386
OS: Linux
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
: 193852 (view as bug list)
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
Reported: 2006-05-23 08:35 UTC by Erik Pedersen
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 1.2.1-1.2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2006-05-23 22:15:53 UTC

Attachments (Terms of Use)
cupsd.conf (deleted)
2006-05-23 11:22 UTC, Erik Pedersen
no flags Details
50-udev.rules (deleted)
2006-05-23 13:26 UTC, Erik Pedersen
no flags Details

Description Erik Pedersen 2006-05-23 08:35:31 UTC
Description of problem:
After an update I can no longer print at all
printer epson disabled since Mon 22 May 2006 07:30:41 AM EDT -
        Unable to open USB device "usb:/dev/usb/lp0": Permission denied
The date here is because I did a reboot

The yum update picked up the following so I am not sure exactly what it is 
that causes the problem

May 21 03:19:09 Updated: glibc-common.i386 2.4-8
May 21 03:19:37 Updated: glibc.i686 2.4-8
May 21 03:19:37 Updated: cups-libs.i386 1:1.2.0-1.1
May 21 03:19:39 Updated: policycoreutils.i386 1.30.8-1.fc5
May 21 03:19:39 Updated: libsane-hpaio.i386 0.9.11-1.1
May 21 03:19:42 Updated: glibc-headers.i386 2.4-8
May 21 03:19:42 Updated: hpijs.i386 1:0.9.11-1.1
May 21 03:19:45 Updated: selinux-policy.noarch 2.2.38-1.fc5
May 21 03:19:47 Updated: mysql.i386 5.0.21-2.FC5.1
May 21 03:20:24 Updated: kdebase.i386 6:3.5.2-7.3.fc5.kde
May 21 03:20:36 Updated: ntp.i386 4.2.0.a.20050816-11.FC5
May 21 03:20:37 Updated: lame.i386 3.96.1-6.lvn5
May 21 03:20:41 Updated: cups.i386 1:1.2.0-1.1
May 21 03:20:43 Updated: libkipi.i386 0.1.4-1.fc5
May 21 03:20:47 Updated: hplip.i386 0.9.11-1.1
May 21 03:20:48 Updated: pirut.noarch 1.0.3-0.fc5
May 21 03:20:49 Updated: libkexif.i386 0.2.3-1.fc5
May 21 03:20:50 Updated: psmisc.i386 22.2-1.1
May 21 03:20:51 Updated: nscd.i386 2.4-8
May 21 03:20:52 Updated: glibc-devel.i386 2.4-8
May 21 03:22:22 Updated: selinux-policy-targeted.noarch 2.2.38-1.fc5
May 21 03:22:23 Updated: vnc-server.i386 4.1.1-38.fc5

Version-Release number of selected component (if applicable):

How reproducible:
Can not print ever

Steps to Reproduce:
1.try to print
Actual results:

Expected results:

Additional info:

Comment 1 Tim Waugh 2006-05-23 08:50:48 UTC
Please attach:

1. your /etc/cups/cupsd.conf, and

2. the output of:

  ls -l /dev/usb/lp0


Comment 2 Tim Waugh 2006-05-23 09:18:53 UTC
Oh, also:

3. the output of 'lpstat -s'

Comment 3 Erik Pedersen 2006-05-23 11:22:06 UTC
Created attachment 129850 [details]

Maybe I should add that the printer worked fine until that update.

Comment 4 Erik Pedersen 2006-05-23 11:33:16 UTC
system default destination: epson
device for epson: usb:/dev/usb/lp0
device for hp: ipp://denal:631/printers/hp

ls -l /dev/usb/lp0
crw------- 1 inger root 180, 0 May 22 08:12 /dev/usb/lp0

Comment 5 Tim Waugh 2006-05-23 12:08:47 UTC
Oh, there's the problem: /dev/usb/lp0 is meant to have 'rw' for group 'lp'.

Have you changed that on purpose?

Comment 6 Erik Pedersen 2006-05-23 12:17:19 UTC
No I did not do anything other than yum update from the core, extras, livna 
and kde-redhat stable repositories. I changed it now, but it does not seem to 
ls -l /dev/usb/lp0
crw-rw---- 1 root lp 180, 0 May 22 08:12 /dev/usb/lp0
[root@laptop inger]# lpstat -p
printer epson disabled since Mon 22 May 2006 07:30:41 AM EDT -
        Unable to open USB device "usb:/dev/usb/lp0": Permission denied

Comment 7 Tim Waugh 2006-05-23 12:18:14 UTC
You might have to re-enable the queue with 'cupsenable epson'.

Comment 8 Erik Pedersen 2006-05-23 12:22:13 UTC
Thanks that did it. I do however still wonder how those permissions got 
changed, I certainly did not change them. I have a cronjob running yum update 
every weekend and all of a sudden sunday I could no longer print. It is 
probably not cups though

Comment 9 Erik Pedersen 2006-05-23 12:46:09 UTC
Except I still can't print. I tried a reboot and then tried to print. Nothing 
happened and the permissions were back to the ones mentioned above. Because of 
a HIGHMEM problem I have to compile the kernel myself on this computer, but I 
take your kernel source, and only change HIGHMEM parameters in the config, but 
of course I exclude kernel from yum update. Could that be the problem? There 
was no reboot before the problem first occurred though

Comment 10 Erik Pedersen 2006-05-23 12:57:31 UTC
OK after every reboot, the permissions on /dev/usb/lp0 are wrong. When I 
correct these permissions I can print now. I don't reboot so often, but 
nevertheless, I wonder where this problem comes from

Comment 11 Erik Pedersen 2006-05-23 13:02:20 UTC
Another strange problem with this printer, epson stylus cx5400, after the 
upgrade to fc5 is that the printer continues blinking after the print job is 
done, and you have to turn that printer on and off to get it back to normal. 
That did not use to happen when i was running fc3. Somehow the print jobs are 
not terminated correctly.

Comment 12 Tim Waugh 2006-05-23 13:12:45 UTC
Could you attach your /etc/udev/rules.d/50-udev.rules file please?

Comment 13 Erik Pedersen 2006-05-23 13:25:22 UTC
I will do that. Actually the permissions and ownerships change whenever I log 
out and in

Comment 14 Erik Pedersen 2006-05-23 13:26:40 UTC
Created attachment 129857 [details]

Comment 15 Erik Pedersen 2006-05-23 13:50:05 UTC
I am using kdm as login manager and kdebase was updated too, so could that be 
the problem? When I log out permissions as seen from another computer get 
changed to root.root 600, I guess that is kdm doing that or what?

Comment 16 Tim Waugh 2006-05-23 14:38:03 UTC
What about /etc/security/console.perms and anything in

Comment 17 Erik Pedersen 2006-05-23 14:46:49 UTC
I am at work now, but I will send them when I get home. I certainly did not 
change anything there not knowing about them, but I looked in there and the 
permissions fit with the fact that this printer is also a scanner, and there 
is a link scanner-lp0 to usb/lp0. Could that be it?

Comment 18 Tim Waugh 2006-05-23 22:15:53 UTC
Sounds like something from livna or kde-redhat has messed that up -- it isn't
supposed to be like that.

Anyway, cups-1.2.1-1.2 makes the usb backend run as root now because of a
separate KDE bug, so that will fix this for the time being.

Comment 19 Tim Waugh 2006-06-07 12:40:04 UTC
*** Bug 193852 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.