Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 192381 - pr(paginate) no longer correctly replaces tabs with spaces
Summary: pr(paginate) no longer correctly replaces tabs with spaces
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: coreutils
Version: 5
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
: 193198 (view as bug list)
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-05-19 04:28 UTC by Landon Kelsey
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 5.96-1.2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-06-20 09:43:07 UTC


Attachments (Terms of Use)

Description Landon Kelsey 2006-05-19 04:28:38 UTC
Description of problem: pr was not on the list so I substituted prctl
pr (paginate no longer replaces tabs with spaces correctly using -e3)


Version-Release number of selected component (if applicable):
pr 5.93
2.6.16-1.2111_FC5 #1 Thu May 4 21:16:58 EDT 2006 i686 i686 i386 GNU/Linux

How reproducible:
landonkateaux (landon) ~/QtFigs4 [1082]>pr -e3 -l60 -f qtfigs.cpp|lp
lp: Unsupported format 'application/octet-stream'!



Steps to Reproduce:
1.pr -e3 -l60 -f qtfigs.cpp|lp
2.
3.
  
Actual results:
landonkateaux (landon) ~/QtFigs4 [1082]>pr -e3 -l60 -f qtfigs.cpp|lp
lp: Unsupported format 'application/octet-stream'!



Expected results: should not get an error and print


Additional info: I've been using this command for years successfully

Comment 1 Karsten Hopp 2006-05-19 09:47:32 UTC
Please read https://bugzilla.redhat.com/bugzilla/page.cgi?id=redhatfaq.html 'How
do I enter a bug?'. There's a chapter how you can find out the bugzilla component
for a given binary.

I'll reassign this to coreutils

Comment 2 Tim Waugh 2006-05-19 09:53:54 UTC
So the problem you're seeing is that 'lp' is failing, not 'pr'.

Comment 3 Tim Waugh 2006-05-19 10:47:25 UTC
Please fetch these RPM files:

  http://people.redhat.com/twaugh/tmp/cups-fc5/i386/

and install them using this command, as root:

  rpm -Fvh cups*-1.2.0-1.3.i386.rpm

Then restart cups:

  /sbin/service cups restart

and try your 'pr ...|lp' command again.  Does it work now?

Comment 4 Landon Kelsey 2006-05-19 14:20:07 UTC
That may work but paginate (pr) is supposed to insert spaces for tabs.

pr -e3 -l60 -f qtfigs.cpp >testx.txt

shows this not being the case

Comment 5 Tim Waugh 2006-05-19 15:42:47 UTC
Please try this test update:

  https://www.redhat.com/archives/fedora-test-list/2006-May/msg00218.html

by fetching:

http://download.fedora.redhat.com/pub/fedora/linux/core/updates/testing/5/i386/coreutils-5.95-1.3.i386.rpm

and installing it ('rpm -Fvh coreutils-5.95-1.3.i386.rpm').

Comment 6 Tim Waugh 2006-05-26 10:38:04 UTC
*** Bug 193198 has been marked as a duplicate of this bug. ***

Comment 7 Landon Kelsey 2006-05-26 12:49:32 UTC
pr now works...thanks!


Note You need to log in before you can comment on or make changes to this bug.