Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 192194 - raw file printing doesn't work after upgrading to cups-1.2.0-1.1
Summary: raw file printing doesn't work after upgrading to cups-1.2.0-1.1
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: cups
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
: 192232 (view as bug list)
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-05-18 09:56 UTC by Steve
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-05-18 16:02:44 UTC


Attachments (Terms of Use)
printconf-tui --Xexport (deleted)
2006-05-18 15:34 UTC, Steve
no flags Details

Description Steve 2006-05-18 09:56:10 UTC
Description of problem:
raw file printing doesn't work afer upgradind to cups-1.2.0-1.1

Version-Release number of selected component (if applicable):
cups-1.2.0-1.1

How reproducible:


Steps to Reproduce:
1.upgrade to cups-1.2.0-1.1
2.print from a remote machine
3.see wath you get and the error_log
  
Actual results:
error:

Print-Job client-error-document-format-not-supported: Unsupported format
'application/octet-stream'

Expected results:


Additional info:

Comment 1 Tim Waugh 2006-05-18 10:30:37 UTC
How about if you run these commands, as root, on the server?:

/usr/sbin/printconf-backend --force-rebuild
/sbin/service cups restart

Comment 2 Steve 2006-05-18 10:54:11 UTC
Nothing appears, same error(s) as before.

Comment 3 Steve 2006-05-18 11:16:52 UTC
There in another error before, here is the log:

I [18/May/2006:13:16:46 +0200] Configured for up to 100 clients.
I [18/May/2006:13:16:46 +0200] Allowing up to 100 client connections per host.
I [18/May/2006:13:16:46 +0200] Using policy "default" as the default!
I [18/May/2006:13:16:46 +0200] Full reload is required.
I [18/May/2006:13:16:46 +0200] Loaded MIME database from '/etc/cups': 34 types,
39 filters...
I [18/May/2006:13:16:46 +0200] Loading job cache file "/var/cache/cups/job.cache"...
I [18/May/2006:13:16:46 +0200] Full reload complete.
I [18/May/2006:13:16:46 +0200] Listening to :::631 on fd 0...
I [18/May/2006:13:16:46 +0200] Listening to 0.0.0.0:631 on fd 2...
E [18/May/2006:13:16:46 +0200] Unable to set ACLs on root certificate
"/var/run/cups/certs/0" - Operation not supported
E [18/May/2006:13:17:14 +0200] Print-Job
client-error-document-format-not-supported: Unsupported format
'application/octet-stream'!

Comment 4 Tim Waugh 2006-05-18 11:53:45 UTC
Please attach the output of 'printconf-tui --Xexport'.  Thanks.

Comment 5 Tim Waugh 2006-05-18 14:57:19 UTC
*** Bug 192232 has been marked as a duplicate of this bug. ***

Comment 6 Steve 2006-05-18 15:34:27 UTC
Created attachment 129436 [details]
printconf-tui --Xexport

Comment 7 Tim Waugh 2006-05-18 15:38:52 UTC
You don't have a raw queue defined, and so printconf doesn't configure CUPS for
raw printing.  At some point, I expect you edited /etc/cups/mime.convs by hand
to enable raw printing.

Using Desktop->Administration->Printing, add a raw print queue.  Just call it
'raw' if you like.  On the 'Printer model' page, scroll down to the bottom and
select 'Raw Print Queue'.

Does printing work now?

Comment 8 Steve 2006-05-18 15:50:44 UTC
it is new in cups 1.2 ??

Comment 9 Steve 2006-05-18 15:55:55 UTC
works just perfect! but this is definitively new in 1.2.

Comment 10 Pasi Sainio 2006-05-18 16:39:09 UTC
Thanks, fixed my problem too!

Comment 11 Tim Waugh 2006-05-18 16:43:11 UTC
This is not new in CUPS-1.2; CUPS-1.1.x behaves in exactly the same way.

In fact it is system-config-printer that does this, changing the mime.types file
automatically depending on whether raw queues are defined.  It has always
behaved that way on FC5.

If you've had raw printing working before without raw queues being defined, you
have edited /etc/cups/mime.types by hand (or some other program has done for
you).  This will always be overwritten whenever you change your printer
configuration or update CUPS.

Comment 12 Steve 2006-05-18 16:55:02 UTC
before 1.2, i never had to do this way!
anyway, thanks for your help...

Comment 13 Tim Waugh 2006-05-18 16:55:59 UTC
But had you edited /etc/cups/mime.types to uncomment the octet-stream line?

Comment 14 Steve 2006-05-18 17:25:43 UTC
yes, i always have (had) to uncomment the octet-stream's in mime.types an
mime.confs.

Comment 15 Steve 2006-05-24 14:19:26 UTC
now, with cups-1.2.1-1.2, it's just perfect, like before, without the "raw share"!


Note You need to log in before you can comment on or make changes to this bug.