Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 191865 - HP Laserjet 4200n prints blank pages
Summary: HP Laserjet 4200n prints blank pages
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-05-16 07:21 UTC by Ville Ranki
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: system-config-printer-0.6.151.7-1.
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-05-23 10:12:32 UTC


Attachments (Terms of Use)
CUPS Error log (deleted)
2006-05-16 14:22 UTC, Ville Ranki
no flags Details
testpage-a4.ps (deleted)
2006-05-16 16:16 UTC, Tim Waugh
no flags Details
PPD file (deleted)
2006-05-17 07:41 UTC, Ville Ranki
no flags Details
PPD file (deleted)
2006-05-17 07:42 UTC, Ville Ranki
no flags Details
testpage-a4.ps (deleted)
2006-05-18 11:11 UTC, Tim Waugh
no flags Details

Description Ville Ranki 2006-05-16 07:21:41 UTC
Description of problem:

HP Laserjet 4200n prints blank pages. The printer 
used to work a few weeks earlier on FC5 and works 
from other operating systems. Used printer config to print
A4 test page.

Version-Release number of selected component (if applicable):
1:1.2.0-1.1

CUPS log:

[16/May/2006:10:24:08 +0300] Adding start banner page "none" to job 20.
[16/May/2006:10:24:08 +0300] Job 20 queued on "SALI_LINKKI" by "root".
[16/May/2006:10:24:08 +0300] Started filter /usr/lib/cups/filter/pstops (PID
3003) for job 20.
[16/May/2006:10:24:08 +0300] Started backend /usr/lib/cups/backend/smb (PID
3004) for job 20.

Comment 1 Tim Waugh 2006-05-16 10:42:37 UTC
So this is a printer connected to a Windows machine?

How about if you print the CUPS test page?  Does that work?

Comment 2 Ville Ranki 2006-05-16 11:49:12 UTC
CUPS test page seems to work. Printing now seems to work from
gedit and openoffice also - they didn't work earlier. Maybe 
editing the printer settings without doing anything or rebooting
helped. The A4 postscript test page still prints blank though.

The printer is a network printer connected with smb.


Comment 3 Tim Waugh 2006-05-16 14:10:03 UTC
How are you printing the A4 PostScript test page -- from the
'Administration->Printing' configuration tool, system-config-printer?

Please edit /etc/cups/cupsd.conf and change the 'LogLevel' line to read:

  LogLevel debug2

Then stop CUPS:

  /sbin/service cups stop

Clear out the log file:

  >/var/log/cups/error_log

and start CUPS again:

  /sbin/service cups start

Try printing the A4 test page again, and then please attach the
/var/log/cups/error_log file.  Thanks.

Comment 4 Ville Ranki 2006-05-16 14:22:22 UTC
Created attachment 129198 [details]
CUPS Error log

Comment 5 Ville Ranki 2006-05-16 14:23:34 UTC
Log attached. I'm using system-config-printer for printing the test page.


Comment 6 Tim Waugh 2006-05-16 14:34:55 UTC
Does this print work?:

lpr -PSALI_LINKKI -oraw /usr/share/printconf/tests/testpage-a4.ps


Comment 7 Ville Ranki 2006-05-16 14:44:42 UTC
Yep, it prints out a good test page.


Comment 8 Tim Waugh 2006-05-16 15:08:25 UTC
Aha.  Sounds like this might be a pstops filter bug.

Please attach /etc/cups/ppd/SALI_LINKKI.ppd.

Comment 9 Tim Waugh 2006-05-16 16:16:15 UTC
Created attachment 129221 [details]
testpage-a4.ps

Actually the cause for this might be a bad testpage-a4.ps file.  Please save
the attached testpage-a4.ps file and print it like this:

lpr -PSALI_LINKKI testpage-a4.ps

Does the output now look as expected?  Just to confirm, the original problem
was that you were getting a blank page in _addition_ to the correctly printed
test page, wasn't it?

Comment 10 Ville Ranki 2006-05-17 07:41:53 UTC
Created attachment 129302 [details]
PPD file

Comment 11 Ville Ranki 2006-05-17 07:42:27 UTC
Created attachment 129303 [details]
PPD file

Comment 12 Ville Ranki 2006-05-17 07:56:15 UTC
The test page you attached prints also as blank. And the problem
is that only one blank paper prints when printing ps test page.


Comment 13 Tim Waugh 2006-05-18 11:11:55 UTC
Created attachment 129408 [details]
testpage-a4.ps

Please try this testpage-a4.ps file instead.

Comment 14 Ville Ranki 2006-05-18 11:30:45 UTC
This file prints correctly.


Comment 15 Fedora Update System 2006-05-22 17:52:03 UTC
Fixed in system-config-printer-0.6.151.7-1.

Comment 16 Ville Ranki 2006-05-23 10:12:32 UTC
I confirm - it works now. Thanks!



Note You need to log in before you can comment on or make changes to this bug.