Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 191731 - libnotify fails to build in Mock
Summary: libnotify fails to build in Mock
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libnotify
Version: rawhide
Hardware: All
OS: Linux
urgent
medium
Target Milestone: ---
Assignee: John (J5) Palmieri
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC6Target BuildReqBlocker
TreeView+ depends on / blocked
 
Reported: 2006-05-15 15:04 UTC by Brian Pepple
Modified: 2013-03-13 04:50 UTC (History)
2 users (show)

Fixed In Version: 0.4.0-2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-07-20 20:09:34 UTC


Attachments (Terms of Use)
Mock Failure Build Log (deleted)
2006-05-15 15:04 UTC, Brian Pepple
no flags Details
Spec file patch (deleted)
2006-06-26 12:17 UTC, Matthias Saou
no flags Details | Diff

Description Brian Pepple 2006-05-15 15:04:04 UTC
Description of problem: libnotify fails to build in Mock

I will be adding a patch for the missing BR later today.

Comment 1 Brian Pepple 2006-05-15 15:04:05 UTC
Created attachment 129071 [details]
Mock Failure Build Log

Comment 2 John (J5) Palmieri 2006-05-15 15:12:23 UTC
No need for a patch.  I need to upgrade to the new version anyway.

Comment 3 Matthias Saou 2006-06-26 12:00:39 UTC
*** Bug 196344 has been marked as a duplicate of this bug. ***

Comment 4 Matthias Saou 2006-06-26 12:16:39 UTC
Well, here is a patch I've tested that fixes the missing build requirements,
sets all the proper requirements for the devel sub-package, and updates to the
latest 0.4.2.

Comment 5 Matthias Saou 2006-06-26 12:17:23 UTC
Created attachment 131523 [details]
Spec file patch

Comment 6 Matthias Saou 2006-07-04 13:58:25 UTC
Could this be taken care of? Seems like it would also fix bug #183238 if I'm not
mistaken.

Comment 7 Jesse Keating 2006-07-10 19:51:06 UTC
Ping.  A mass rebuild is scheduled for tomorrow, July 11th.  Please try to have
your package fixed by then.

Comment 8 Matthias Saou 2006-07-20 09:44:26 UTC
I see that this package got rebuilt a couple of times in Rawhide yesterday...
John, do you think you could make this simple update ASAP?

Comment 9 Nalin Dahyabhai 2006-07-20 20:09:34 UTC
The changelog suggests that Jesse fixed this in 0.4.0-2, and libnotify 0.4.0-3.2
rebuilds cleanly in mock with today's Raw Hide tree.  Closing.

Comment 10 Matthias Saou 2006-07-21 08:35:42 UTC
Ahem... I was actually referring to the update to 0.4.2 which is still required.
I guess I'll simply reopen bug #196344 then...


Note You need to log in before you can comment on or make changes to this bug.