Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 191581 - Lots of /usr/share/locale/* are not owned by a package
Summary: Lots of /usr/share/locale/* are not owned by a package
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: filesystem
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Bill Nottingham
URL:
Whiteboard:
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-05-13 09:05 UTC by Robert Scheck
Modified: 2014-03-17 02:59 UTC (History)
1 user (show)

Fixed In Version: 2.4.0-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-10-14 09:44:26 UTC


Attachments (Terms of Use)

Description Robert Scheck 2006-05-13 09:05:19 UTC
Description of problem:
When I'm doing the following on my system,

$ rpm -qf /usr/share/locale/* | grep -c "is not owned"
90
$
$ rpm -qf /usr/share/locale/* | grep -v -c "is not owned"
49
$

then I'll come to the result, that about 90 directories in /usr/share/locale/* 
are not owned, but only 49 are owned by glibc-common and man. IMHO that's wrong 
and also not clean packaged.

Version-Release number of selected component (if applicable):
fedora-release-5.89-rawhide

How reproducible:
See above.

Actual results:
Lots of unowned directories and subdirectories in /usr/share/locale

Expected results:
All directories and subdirectories owned by a package.

Additional info:
The mess comes normally up, when there is no man page or glibc translation 
available for the corresponding language. Let me take the following:
  /usr/share/locale/dz/LC_MESSAGES/glib20.mo

What the hell is owned here by a package except /usr/share/locale and the file 
itself? Nothing...

I filed this bug against distribution, because I don't know which package could 
be suitable.

Comment 1 Jeff Johnson 2006-06-23 12:51:28 UTC
Hint: Try a i18n-filesystem package that contains the /usr/share/locale directory skeleton with %lang as 
appropriate.

Comment 2 Robert Scheck 2006-06-26 12:18:10 UTC
I opened up bug #196669, which proposes a filesystem-i18n package for Fedora 
Core. Alternatively, the filesystem-i18n package could be merged into the 
existing filesystem package, if there are no contras for doing this.

Comment 3 Rex Dieter 2006-06-29 18:42:00 UTC
IMO, these bits ought to be in the filesystem package.

Comment 4 Robert Scheck 2006-06-29 18:53:46 UTC
Fix it where ever you want, but fix it please :)

BTW, more locales are listed at: http://www.debian.org/international/l10n/po/ 
and in /usr/share/gettext/intl/config.charset there are also locales listed but 
guess Fedora/Red Hat will have to maintain the locales list manually anyway.


Comment 5 Robert Scheck 2006-10-14 09:44:26 UTC
This bug report got fixed by resolving bug #196669. Finally, a bit is missing 
which is tracked down in bug #210749. Closing here...


Note You need to log in before you can comment on or make changes to this bug.