Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 191488 - initrd getting overwritten at current load address?
Summary: initrd getting overwritten at current load address?
Keywords:
Status: CLOSED DUPLICATE of bug 234681
Alias: None
Product: Fedora
Classification: Fedora
Component: qemu
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-12 13:13 UTC by Mark McLoughlin
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-01 08:14:35 UTC


Attachments (Terms of Use)

Description Mark McLoughlin 2006-05-12 13:13:28 UTC
With latest rawhide qemu (qemu-0.8.0-6.fc6) and kernel (2.6.16-1.2200_FC6) if
you try to run qemu with -kernel and -initrd, you get an error like:

checking if image is initramfs...it isn't(bad gzip magic numbers); looks like an
initrd

Sticking in some debugging printks it seems that the contents of the initramfs
are being overwritten at some point with a load address of 0x400000. I tried
increasing the load address and it eventually worked at 0x800000.

This post to qemu-devel confirms the issue:

http://www.mail-archive.com/qemu-devel@nongnu.org/msg04606.html

However, that reporter indicated that it was the kernel size that was the issue
for him whereas in our case the kernel fits happily between 0x100000 and
0x400000, so I'm not sure what's actually causing the overrun here.

Comment 1 Hans de Goede 2006-11-14 23:00:11 UTC
All supported releases (FC-5, FC-6 and devel) currently have qemu-0.8.2, can you
retest with this version and report back here?

Thanks!


Comment 2 Hans de Goede 2007-03-18 19:23:56 UTC
Repeating myself (PING):

All supported releases (FC-5, FC-6 and devel) currently have qemu-0.8.2, can you
retest with this version and report back here?

Thanks!



Comment 3 Hans de Goede 2007-04-01 08:14:35 UTC

*** This bug has been marked as a duplicate of 234681 ***


Note You need to log in before you can comment on or make changes to this bug.