Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 190041 - session should set proxy information in environment
Summary: session should set proxy information in environment
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-session
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
: 204482 (view as bug list)
Depends On:
Blocks: FC6Target FC6Desktop
TreeView+ depends on / blocked
 
Reported: 2006-04-26 21:46 UTC by Jeremy Katz
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-09-06 16:05:17 UTC


Attachments (Terms of Use)

Description Jeremy Katz 2006-04-26 21:46:27 UTC
gnome-session should probably set HTTP_PROXY, etc if you set up a network proxy
in control-center so that non-GNOME apps have a chance of working.

Comment 1 Matthias Clasen 2006-07-06 21:54:33 UTC
Add to FC6Destop tracker

Comment 2 Mark McLoughlin 2006-07-13 10:00:26 UTC
gnome-terminal already does this - see:

  http://bugzilla.gnome.org/show_bug.cgi?id=321952

agreed, though, that this should probably be in gnome-session. I've re-opened
the upstream bug:

  http://bugzilla.gnome.org/show_bug.cgi?id=84315

Comment 3 Ray Strode [halfline] 2006-07-25 19:29:39 UTC
what apps depend on http_proxy (that aren't run from terminal) ?

We should just go with whatever upstream does I think.

Comment 4 Jeremy Katz 2006-09-06 04:22:50 UTC
I really think we need to do this, even if it's adding a patch ourselves.  Right
now, it's extremely non-obvious how to do any sort of proxy setting for a) any
non-GNOME app b) any app not running as the user (eg, pup/pirut).

And I really don't think that "add proxy config to pup/pirut" is the right
answer here...

Comment 5 Jeremy Katz 2006-09-06 04:23:24 UTC
*** Bug 204482 has been marked as a duplicate of this bug. ***

Comment 6 Ray Strode [halfline] 2006-09-06 16:05:17 UTC
Ohh, this is for pirut! Okay.  It would be better, long term, if pirut dropped
privileges and used gconf itself, I think, but I realize that has its own
complications.

Should be fixed in the next compose.  Reopen, if not.  I haven't really tested
it, so there might be issues.

Comment 7 Marius Andreiana 2006-09-12 16:47:28 UTC
It also works if the automatic configuration option is selected?


Note You need to log in before you can comment on or make changes to this bug.