Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 189981 - Authconfig-tui present unusable screen under Polish locale set.
Summary: Authconfig-tui present unusable screen under Polish locale set.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: newt
Version: rawhide
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact:
URL:
Whiteboard:
Depends On: 185950
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-04-26 13:54 UTC by Petr Rockai
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-05-31 14:41:13 UTC


Attachments (Terms of Use)

Description Petr Rockai 2006-04-26 13:54:59 UTC
Note to self: do not forget about this issue in devel, examine the 
int->unsigned changes more closely and check for other possible regressions 
introduced by this change.

+++ This bug was initially created as a clone of Bug #185950 +++

Description of problem:
If Polish locale selected as system locale, the authconfig-tui presents no
useful screen on console. It consists only of blue bkg and movement tips at 
the
very last row of the screen (localized strings). However authconfig-tui 
reacts
on movement keys pressed ie. space, ESC or F12.
If it is run with C locale it presents full workable screen.

Version-Release number of selected component (if applicable):
authconfig-5.2.2-1

How reproducible:
After fresh install with no graphic desktops/X, when firstboot invokes
authconfig via setup or
on every run as root on console/xterm with Polish locale set.

Steps to Reproduce:
1.Fresh install with no X/Desktop and set Polish locale as system one, then
allow firstboot to invoke setup and authconfig. OR
2.Run it from command line or throuh setup tools on console/xterm as root.
  
Actual results:
Only unusable blue screen.

Expected results:
Usable screen with options to check/uncheck to set up authentication of the 
system.

Additional info:

-- Additional comment from rabe@epf.pl on 2006-03-20 06:58 EST --
Created an attachment (id=126345)
Scrshot of authconfig being run with Polish Locale (under xterm)


-- Additional comment from tmraz@redhat.com on 2006-03-20 09:02 EST --
Seems to be a newt toolkit problem as it works fine with the same 
authconfig
version on FC-4.

Workaround - make the terminal window wider.


-- Additional comment from rabe@epf.pl on 2006-03-21 01:01 EST --
Hmm??? Make a terminal window wider.... But it also happens in bare 
console
outside xterm.. It happens during firstboot in text mode. Setting higher 
VGA
mode in console doesn't help.

-- Additional comment from clumens@redhat.com on 2006-03-28 10:41 EST --
*** Bug 186907 has been marked as a duplicate of this bug. ***

-- Additional comment from clumens@redhat.com on 2006-03-28 11:32 EST --
This is a problem that's turned up in the text parts of the installer 
(ethernet
device screen, partitioning screen), firstboot, and various configuration 
tools.
 What we've determined matches up with what Tomas says - the text is too 
large
for the terminal, so newt simply doesn't draw the dialog on the screen.  
This is
a regression from FC4.

Attached is a reproducer in python for this bug.  Make sure your terminal 
is
under 200 columns.  Note that we can't resize the console, so this is a big
problem for us.

#!/usr/bin/python

from snack import *

li = Listbox(5, returnExit = 1)
li.append("a"*200, "f")
screen = SnackScreen()
g = Grid(1, 3)
g.setField(li, 0, 1, (0, 1, 0, 1))
g.place(1, 1)
screen.gridWrappedWindow(g, "title")
f = Form("This is some help")
f.add(li)
res = f.run()
screen.popWindow()
screen.finish()

-- Additional comment from tmraz@redhat.com on 2006-03-28 15:41 EST --
Created an attachment (id=126932)
Proposed patch

This patch fixes the regression.


-- Additional comment from prockai@redhat.com on 2006-04-03 17:54 EST --
Thanks Tom for the patch. An updated newt resolving this issue has been 
pushed to fc5 updates.

Comment 1 Miroslav Lichvar 2006-05-31 14:41:13 UTC
Fixed in newt-0.52.2-6.1.


Note You need to log in before you can comment on or make changes to this bug.