Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 189030 - RFE: make hplip-gui require reportlab
Summary: RFE: make hplip-gui require reportlab
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: hplip
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-04-14 22:14 UTC by Bernard Johnson
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 2.7.6-2.fc8
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-07-06 11:26:34 UTC


Attachments (Terms of Use)

Description Bernard Johnson 2006-04-14 22:14:36 UTC
Description of problem:
Without reportlab installed, cover sheets can not be created for hp-sendfax. 
Without the ability to customize cover sheets, the value of a program like
hp-sendfax is compromised.

Version-Release number of selected component (if applicable):
hplip-0.9.10-4

How reproducible:
always


Steps to Reproduce:
1. hp-sendfax
2.
3.
  
Actual results:
[bjohnson@localhost ~]$ hp-sendfax
 [ERROR]: Coverpages disabled. Reportlab not installed.

HP Linux Imaging and Printing System (ver. 0.9.10)
PC Sendfax Utility ver. 1.7


Expected results:


Additional info:

Comment 1 Tim Waugh 2006-04-24 13:09:25 UTC
You can just 'yum install reportlab' to get it from Fedora Extras.  I don't
think we can have a Base package actually *require* an Extras package.

Comment 2 Bernard Johnson 2006-04-25 16:00:47 UTC
Oh, I didn't realize it was in extras.  I tried "yum install reportlab" as even
you suggested and assumed it was not available.  By the way, it's
python-reportlab, which is why I didn't find it ;)

I agree that you can't have a base package require an extras package.  It seems
to me, since it provides a vital piece of functionality for a base package that
maybe it should be in core. (Yeah, I know how people scream when that type of
thing is suggested).  I really don't know the exact criteria for doing such, so
just take this as MHO.

By the way, reportlab is borken anyway :)  bug #189894.

Comment 3 Bernard Johnson 2007-03-23 20:57:33 UTC
(In reply to comment #1)
> You can just 'yum install reportlab' to get it from Fedora Extras.  I don't
> think we can have a Base package actually *require* an Extras package.

This should be a non-issue with the core/extras merge coming up.

Comment 4 Bernard Johnson 2007-07-05 18:26:15 UTC
Any thoughts on putting this in F7 & rawhide now that merge is completed?



Comment 5 Tim Waugh 2007-07-06 11:26:34 UTC
Unfortunately the scanning stuff is in the main package, so the dependency needs
to go there.

Comment 6 Bernard Johnson 2007-07-06 17:32:39 UTC
If I understand it correctly, hp-sendfax runs fine without reportlab, you just
can't send a cover page without it.  But the interactive mode doesn't have any
way to use the cover page editor, so there doesn't need to be a dependency
there.  But you could put the dependency in the gui package because only the gui
mode of hp-scanfax has the ability to use it.  Did I miss something there?

Comment 7 Tim Waugh 2007-07-09 09:49:49 UTC
Ah, I see.  Fixed in 2.7.6-4.fc8.


Note You need to log in before you can comment on or make changes to this bug.