Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 188985 - hp-sendfax cannot fax to network printer
Summary: hp-sendfax cannot fax to network printer
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hplip
Version: 5
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On: 191444
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-04-14 08:05 UTC by Bernard Johnson
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-05-31 23:57:02 UTC


Attachments (Terms of Use)
return channel id in device.cpp (deleted)
2006-04-17 16:52 UTC, Bernard Johnson
no flags Details | Diff
return channel id in device.cpp (deleted)
2006-04-17 19:15 UTC, Bernard Johnson
no flags Details | Diff

Description Bernard Johnson 2006-04-14 08:05:28 UTC
Description of problem:
hp-sendfax prints errors and is unable to send a fax

Version-Release number of selected component (if applicable):
hplip-0.9.9-5.1

How reproducible:
always

Steps to Reproduce:
1. /usr/bin/hp-sendfax
2. select a recipient
3. select a file
4. click "send fax"
  
Actual results:
[bjohnson@localhost ~]$ hp-sendfax
 [ERROR]: Coverpages disabled. Reportlab not installed.

HP Linux Imaging and Printing System (ver. 0.9.9)
PC Sendfax Utility ver. 1.7

Copyright (c) 2003-6 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

QSettings: failed to open file '/usr/lib/qt-3.3/etc/settings/qt_plugins_3.3rc'
sendfax Using device: hpfax:/net/HP_Color_LaserJet_2840?ip=192.168.1.1
sendfax [ERROR]: Unable to open channel (Unknown internal error).
sendfax [ERROR]: Fax send error.
sendfax [ERROR]: Error, aborting.
[bjohnson@localhost ~]$


Expected results:
Fax to be sent.

Additional info:
I also tried this with selinux in permissive mode.

Comment 1 Bernard Johnson 2006-04-17 16:52:59 UTC
Created attachment 127812 [details]
return channel id in device.cpp

I'm beginning to think that this could not have ever worked for anyone. 
Attached is a patch to get past the "Unknown internal error".  It appears that
the communication protocol between device.py and device.cpp (hpiod) is broken.

Once I apply this patch, I get further - to the point that my fax is detected
in the idle state and needs to go to ready state (long debug log not attached
at this time).	Unfortunately, it then fails with this error:

sendfax [ERROR]: Could not get into active state!
sendfax [ERROR]: D/L error state=2
sendfax [ERROR]: Fax send error.
sendfax [ERROR]: Error, aborting.

Comment 2 Bernard Johnson 2006-04-17 19:15:00 UTC
Created attachment 127822 [details]
return channel id in device.cpp

fixed typo

Comment 3 Tim Waugh 2006-04-18 16:50:38 UTC
From the upstream discussion (thanks) it looks like we should hold off applying
this patch for the moment.

Comment 4 Bernard Johnson 2006-04-18 17:07:49 UTC
Definately - it seems my patch does nothing more than cover up the error.

Comment 5 Bernard Johnson 2006-04-19 02:52:29 UTC
Seems hplip is using the wrong port.  The hplip guys are on it.
http://www.mail-archive.com/hplip-devel@lists.sourceforge.net/msg00031.html

Comment 6 Bernard Johnson 2006-05-10 16:00:09 UTC
Tim,

I downloaded the just released hplip-0.9.11, built, and tested it.  The fax
capability seems to work just fine in this release.

Comment 7 Bernard Johnson 2006-05-11 23:40:12 UTC
I just tested your hplip-0.9.11-1.1 from updates-testing.  Everything in hplip
looks good, however, the port changed required to fix the bug has caused selinux
to complain.

Comment 8 Tim Waugh 2006-05-12 08:01:48 UTC
What AVC message do you see?

Comment 9 Bernard Johnson 2006-05-12 14:29:38 UTC
bugzilla #191444

Comment 10 Bernard Johnson 2006-05-31 23:57:02 UTC
Tested with hplip-0.9.11-1.2.  Working fine.


Note You need to log in before you can comment on or make changes to this bug.