Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 188750 (pirutcd) - pirut needs to support CD repositories
Summary: pirut needs to support CD repositories
Keywords:
Status: CLOSED RAWHIDE
Alias: pirutcd
Product: Fedora
Classification: Fedora
Component: pirut
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
: 72186 73329 76917 135534 171572 173965 176568 182041 182473 187189 190223 219707 (view as bug list)
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-04-12 18:55 UTC by Jeremy Katz
Modified: 2007-11-30 22:11 UTC (History)
26 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-09-18 19:05:35 UTC


Attachments (Terms of Use)

Description Jeremy Katz 2006-04-12 18:55:18 UTC
With the move to pirut from system-config-packages, we have lost the ability to
install packages from CD post-install.  This is a loss for people who don't have
a fast network connection or just want to use CDs.

To resolve this, we need to get more of the CD support in anaconda merged into
yum itself.  This *must* be done for FC6

Comment 1 Jeremy Katz 2006-04-12 18:59:47 UTC
*** Bug 182041 has been marked as a duplicate of this bug. ***

Comment 2 Jeremy Katz 2006-04-12 19:00:05 UTC
*** Bug 187189 has been marked as a duplicate of this bug. ***

Comment 3 Jeremy Katz 2006-04-12 19:00:57 UTC
*** Bug 182473 has been marked as a duplicate of this bug. ***

Comment 4 John Thacker 2006-04-22 01:21:10 UTC
*** Bug 135534 has been marked as a duplicate of this bug. ***

Comment 5 John Thacker 2006-04-22 01:23:24 UTC
*** Bug 173965 has been marked as a duplicate of this bug. ***

Comment 6 John Thacker 2006-04-22 01:24:08 UTC
*** Bug 176568 has been marked as a duplicate of this bug. ***

Comment 7 John Thacker 2006-04-22 01:27:26 UTC
*** Bug 171572 has been marked as a duplicate of this bug. ***

Comment 8 John Thacker 2006-04-22 04:12:23 UTC
*** Bug 72186 has been marked as a duplicate of this bug. ***

Comment 9 John Thacker 2006-04-22 04:14:33 UTC
*** Bug 73329 has been marked as a duplicate of this bug. ***

Comment 10 John Thacker 2006-04-22 04:21:41 UTC
*** Bug 76917 has been marked as a duplicate of this bug. ***

Comment 11 Jeremy Katz 2006-05-01 18:21:51 UTC
*** Bug 190223 has been marked as a duplicate of this bug. ***

Comment 12 Andrew D. Stadler 2006-05-22 21:27:01 UTC
Yes yes yes!

Comment 13 drago01 2006-06-28 15:16:33 UTC
any progress on this?
will it be ready for test2?

Comment 14 Laurent Rineau 2006-08-23 12:38:54 UTC
Is this bug WONTFIX? I can imagine that, even if a fix arises, it will be too 
late for FC-6.


Comment 15 adam 2006-09-29 13:52:18 UTC
So much work in vain. This system is worthless without it.

Comment 16 Need Real Name 2006-10-15 22:48:47 UTC
This is unbelievable. 

I just installed FC5 in order to work on a project that specifically requires FC5.

The machine in question doesn't have internet access so I've got something less
useful than a brick (at least you can pile up bricks and make a nice garden
wall).  The package manager just plain can't deal with CDs?  Who thought it was
a bright idea to eliminate support for CD installations?

And it's been like this for 6 months now?

I sure won't recommend FC to anybody after this...

Comment 17 Sergio Monteiro Basto 2006-10-25 17:21:22 UTC
if you edit /etc/yum.repos.d/fedora-core.repo 
and put baseurl=file:///media/disk

pirut works with DVD , don't know what is your problem 

better with an iso 
mount -o loop ~sergio/Zod-dvd-i386/FC-6-i386-DVD.iso /mnt/disk
and put baseurl=file:///mnt/disk 
works beautifully


Comment 18 josip 2006-10-28 08:03:28 UTC
Yum access is broken, despite baseurl=file:///mnt/fc6/ where the DVD image is
loop mounted:

/fedora-core/6/i386/iso/FC-6-i386-DVD.iso on /mnt/fc6 type iso9660
(ro,loop=/dev/loop0)

Yum clean, check-update, and list work fine; but yum install is broken (this
also affects pirut):

# yum install zsh
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for zsh to pack into transaction set.
media://1161131669.029329%234/Fedora/RPMS/zsh-4.2.6-1.i386.rpm: [Errno 4]
IOError: <urlopen error unknown url type: media>
Trying other mirror.
Error: failed to retrieve Fedora/RPMS/zsh-4.2.6-1.i386.rpm from core
error was [Errno 4] IOError: <urlopen error unknown url type: media>

See also bug #212180


Comment 19 Jeremy Katz 2006-12-14 21:13:08 UTC
*** Bug 219707 has been marked as a duplicate of this bug. ***

Comment 20 Arkady L. Shane 2007-02-21 14:19:39 UTC
Tue, 20 Feb 2007 GMT - Jeremy Katz <katzj@redhat.com> - 1.3.0-1
- Fix a translation problem (#228237)
- Start of support for CDs.  To test for now, you need to have yum 3.1.2 
  and add a mediaid= line to your repo.  mediaid is the first line 
  of .discinfo from your media


Comment 21 Sergio Monteiro Basto 2007-07-16 20:32:06 UTC
yum-3.2.0 and yum-3.2.1 seems to work again thanks! 
this bug could be close ? 

Comment 22 Christian Nolte 2007-07-17 07:34:21 UTC
IMHO this bug should not be closed because for the normal end-user it is too
much of a hassle to edit configuration files to get support for
media-repositories. I suggest to add some chooser to pirut so that the user can
select "Install from CD/DVD" or "Install via Internet" or something like that.
Another option is the detection of install-media using HAL. yum and pirut could
then act appropriately.

Comment 23 Jeremy Katz 2007-09-18 19:05:35 UTC
With Fedora 8, things will be set up so that you get a media repo set up
automatically if you've done your installation from a media source.  This will
then make things automatic and work nicely for those who have the media enabled.
 You'll also be able to then disable the repository within pirut if you no
longer have the DVD


Note You need to log in before you can comment on or make changes to this bug.