Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 188482 - Review Request: scipy-0.4.8
Summary: Review Request: scipy-0.4.8
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Thorsten Leemhuis (ignored mailbox)
QA Contact: Fedora Package Reviews List
Depends On:
TreeView+ depends on / blocked
Reported: 2006-04-10 15:14 UTC by Neal Becker
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2006-09-15 03:39:52 UTC

Attachments (Terms of Use)

Description Neal Becker 2006-04-10 15:14:18 UTC
Spec Name or Url:
SRPM Name or Url:
Description: scientific python.  This version is for numpy-0.9.6

Comment 1 Ed Hill 2006-04-29 15:14:50 UTC
Hi Neal, the two URLs return "404 Not Found" for me.  Is this submission

Comment 3 Ed Hill 2006-05-01 15:16:09 UTC
Hi Neal, this isn't a full review, just a few quick observations:

 - Is this your first package?  If so, we'll add FE-NEEDSPONSOR per:
 - incorrect BuildRoot:
 - please either make Source0 a full URL or indicate (with some 
     comments in the spec file) how one can generate the tar-ball 
     from, for instance, the upstream CVS [this is so we can more 
     easily verify that source matches upstream] 
 - please remove Prefix and Vendor
 - please add a changelog
 - please consider changing %defattr(-,root,root) to 

You might want to take a look at the review guidelines:

and build your rpm in mock ("yum install mock") and run your generated 
RPM through rpmlint ("yum install rpmlint") to see if you might find any 
other items -- it could make the job easier easier for reviewers!

Comment 4 Neal Becker 2006-05-04 00:08:44 UTC
OK, I have uploaded scipy-0.4.8-2.  I have tried to address the comments.

I did not use mach, because the setup looks a bit involved.  I did try to 
supply requires and buildrequires manually.

I did run rpmlint.  There are some complaints, but I think they are ignorable.

I removed d1mach patch.  If you have the latest FC5 gcc I think the bug has 
been fixed.  Is it safe to assume nobody will try to use older gcc?

Comment 5 Ed Hill 2006-05-06 17:15:31 UTC
Hi Neal, heres a few more comments (not a thorough review):

 + license is OK: its BSD-w/o-advertise-clause
 + source matches upstream

 - missing license file (please add "%doc LICENSE.txt")
 - missing "BuildRequires: numpy"
 - please use "%setup -q"

Also, *please* build your package locally in mock.  The commands are:

 1) yum install mock
 2) add yourself to the mock group (vi /etc/group)
 3) log out/in for group addition to take full effect
 4) run "mock -r fedora-5-i386-core scipy-0.4.8-2.src.rpm"

and it will help you identify problems.  Its a very good idea since 
mock is what the buildsystem itself uses.

Comment 6 Neal Becker 2006-05-08 18:43:07 UTC
I believe I have done all that was requested.  Updated srpm is here

Comment 7 Neal Becker 2006-05-08 19:09:42 UTC
Sorry make that:

Comment 8 Laurent Rineau 2006-05-16 13:15:53 UTC
Mass-block FE-NEEDSPONSOR for the six review requests¹ of Neal Becker. Neal, 
when you get sponsorship, you will have to unblock it for all your requests.

¹) Actually the four that do not block yet FE-NEEDSPONSOR.

Comment 9 Ed Hill 2006-05-16 14:25:19 UTC
Hi Neal, this is still not a complete review but we have at this point 
covered a number of the review items.

 + builds in mock on FC5 i386
 + dir ownership appears to be OK
 + permissions look OK

 - rpmlint returns 168 errors/warnings of which 167 are:

     126 are devel-file-in-non-devel-package
     39  are non-executable-script
     2   are script-without-shellbang

   and these can probably be safely ignored.  The one remaining 
   warning is:

       W: scipy summary-ended-with-dot Scipy: array processing 
          for numbers, strings, records, and objects.

   and you can easily fix it.

 1) There are a number of files in directories of the form 
    Perhaps they should go in sub-packages such as scipy-test and 
    scipy-docs or similar?  Whats your opinion of putting them in 
 2) What is your sponsorship status?  Are any of the other packages 
    you submitted closer to passing review?  I'm just a little leery 
    about sponsoring you since I'm not familiar with any of the other 
    packages and just don't have enough free time to learn about them.

Note You need to log in before you can comment on or make changes to this bug.