Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 188215 - Undefined symbol
Summary: Undefined symbol
Keywords:
Status: CLOSED DUPLICATE of bug 185777
Alias: None
Product: Fedora
Classification: Fedora
Component: compat-wxPythonGTK2
Version: 5
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-04-07 01:38 UTC by Joel Schaerer
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-04-22 22:17:41 UTC


Attachments (Terms of Use)

Description Joel Schaerer 2006-04-07 01:38:32 UTC
Description of problem:
When importing wx:

  File "/home/schaerer/bin/Visu3D.py", line 5, in ?
    from wxPython.wx import *
  File "/usr/lib/python2.4/site-packages/wxPython/__init__.py", line 20, in ?
    import wxc
ImportError: /usr/lib/libwx_gtk2-2.4.so.0: undefined symbol: pango_x_get_context


Version-Release number of selected component (if applicable):

 wxPythonGTK2            i386       2.4.2.4-7        extras            4.7 M
 compat-wxGTK2           i386       2.4.2-17.fc5     extras            1.7 M
 compat-wxGTK2-gl        i386       2.4.2-17.fc5     extras             19 k

How reproducible:

Always

Steps to Reproduce:
1. Import wxPython.wx
2. watch crash
3.

Comment 1 Matthew Miller 2006-04-07 02:37:38 UTC
This is known and in-progress. Can't realistically work on it until after
fudcon, though -- sorry. But I know a lot of people are depending on this so it
_will_ get done soon.

*** This bug has been marked as a duplicate of 163440 ***

Comment 2 Joel Schaerer 2006-04-22 18:46:05 UTC
Bug number 163440 has been closed, but the problem is still there. I upgraded to
the latest version in fc5, that is:

compat-wxPythonGTK2-2.4.2.4-11.fc5

and I get the same bug:

Traceback (most recent call last):
  File "/usr/lib/DaVaW/DaVaW/demo/demo.py", line 25, in ?
    from   wxPython.wx import *
  File "/usr/lib/python2.4/site-packages/wxPython/__init__.py", line 20, in ?
    import wxc
ImportError: /usr/lib/libwx_gtk2-2.4.so.0: undefined symbol: pango_x_get_context

So I'm reopening the bug, I hope it's the right thing to do?

Comment 3 Matthew Miller 2006-04-22 19:04:34 UTC
The latest version of wxPython 2.4.x is compat-wxPythonGTK2-2.4.2.4-11.fc5, but
unless you specifically need the old version (which is not maintained upstream),
it is recommended that you use the new wxPython 2.6.x package instead.


The specific bit that's failing there -- just importing things -- should work
fine. It's possible that something else in the code is incompatible, though.
Have you tested that?



Comment 4 Joel Schaerer 2006-04-22 21:51:52 UTC
I'm not sure what you're asking, but yes, I specifically need wxPython 2.4. I'm
trying to run a library that hasn't been ported to the latest wxPython yet.

Since something so simple as the import fails, I suppose there is something
wrong with the package. Have you tested it?

Comment 5 Matthew Miller 2006-04-22 22:17:41 UTC
Yeah, it's a Known Thing that the 2.4.x compat package is broken. See bug #185777.

In fact, I'm going to mark this as a dup of that.

I hadn't actually tried installing the compat package before, so this is the
first that I noticed that installing that breaks *everything*. Urgh.



*** This bug has been marked as a duplicate of 185777 ***


Note You need to log in before you can comment on or make changes to this bug.