Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 187703 - Unable to share printer in FC5
Summary: Unable to share printer in FC5
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC6Target 187725
TreeView+ depends on / blocked
 
Reported: 2006-04-03 00:52 UTC by Stephen John Smoogen
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 1.2.1-1.7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-06-20 10:25:43 UTC


Attachments (Terms of Use)
cupsd configuration that causes 403 errors (deleted)
2006-06-07 12:55 UTC, Derek Atkins
no flags Details

Description Stephen John Smoogen 2006-04-03 00:52:26 UTC
Description of problem:

Installed FC5, and setup printer for printing. Printer is able to print locally. 
Started system-config-printer to try and get printer to share:

Got error message
No match for USB device:
  mfr "Brother"
  model "HL-1850_1870N series"
  desc ""
  cmdset "PJL,PCL,PCLXL,POSTSCRIPT"
Please report this message in Bugzilla:
  https://bugzilla.redhat.com/bugzilla
Choose 'foomatic' as the component.

Clicked on printer, clicked on sharing 
Clicked on "This queue is available to other computers"
Added 192.168.1.0/255.255.255.0
Clicked OK  [Closed network window]
Clicked OK  [Closed share window]
Clicked OK [ Closed "Edit a print quueue"]
Clicked APPLY
Checked netstat -natp
  Saw that cups was still listening on localhost only.
  Checked /etc/cups/ file and saw that nothing was there that I had put in.

Restarted tool, repeated steps
Redid the changes and put in /24 instead. Saw this get changed to 255.255.255.0
Cups began listening on all networks.
Weird.

Comment 1 Tim Waugh 2006-04-03 08:52:50 UTC
There are two unrelated issues here:

1. That sharing a queue did not work, and
2. That your printer is not automatically detected


Comment 2 Tim Waugh 2006-04-03 08:54:41 UTC
This is number 1.

Comment 3 Derek Atkins 2006-06-07 12:21:19 UTC
Yeah, it looks like the CUPS "Allow from @IF(ifname)" doesn't quite work right
in FC5.  I kept getting a "403 Permission Denied" when configured that way.  As
soon as I changed the configuration from Interface to IP Address, it worked great.

Comment 4 Tim Waugh 2006-06-07 12:46:25 UTC
Derek, the original description didn't mention '@IF(ifname)' -- perhaps you are
seeing a separate bug?

Anyway, please attach the /etc/cups/cupsd.conf that exhibits the problem, and
tell me how to see the '403 Permission Denied' error.  Thanks.

Comment 5 Derek Atkins 2006-06-07 12:55:03 UTC
Created attachment 130675 [details]
cupsd configuration that causes 403 errors

Yeah, it could be a separate bug, but it sounded similar -- especially the fact
that changing to a network/netmask solved the problem for me.

As for how to see the 403 Permission Denied error, just try to access
http://<cupsd-ip>:631/printers/printer from a host on 'vmnet8' or 'vmnet1' and
you'll see it.	Accessing /printers works fine... But then when you click on
"printer" it gives you a 403.

(If you can't tell, this was an attempt to get my vmware guest system to print
using my linux-host cups configuration..   and it was working just fine in FC3
until I updated my machine the other day).

Comment 6 Tim Waugh 2006-06-07 14:43:12 UTC
Thanks.

Reported upstream (with fix):

  http://cups.org/str.php?L1758


Comment 7 Tim Waugh 2006-06-08 10:49:31 UTC
Please try this test update:

  https://www.redhat.com/archives/fedora-test-list/2006-June/msg00081.html

You should be able to try this out using this command, as root:

  yum --enablerepo=updates-testing update 'cups*'


Comment 8 Tim Waugh 2006-06-20 10:25:43 UTC
Anyway, works here.

Comment 9 Derek Atkins 2006-06-20 12:18:11 UTC
Oops, sorry, forgot to respond to this.  Yes, I updated and yes this fixed it.
Thanks


Note You need to log in before you can comment on or make changes to this bug.