Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 187021 - shared-mime-info defaults.list should include an entry for inode/directory
Summary: shared-mime-info defaults.list should include an entry for inode/directory
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: shared-mime-info
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
: 188464 (view as bug list)
Depends On:
Blocks: FC6Target FC5Update FC6Desktop
TreeView+ depends on / blocked
 
Reported: 2006-03-28 03:49 UTC by Uno Engborg
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-07-26 17:19:27 UTC


Attachments (Terms of Use)
gconftool-2 -R /desktop/gnome/url-handlers (deleted)
2006-03-30 01:18 UTC, Uno Engborg
no flags Details
/usr/share/applications/defaults.list (deleted)
2006-03-30 01:19 UTC, Uno Engborg
no flags Details
/usr/share/applications/mimeinfo.cache (deleted)
2006-03-30 01:22 UTC, Uno Engborg
no flags Details

Description Uno Engborg 2006-03-28 03:49:34 UTC
Description of problem:

When selecting  Places->Desktop I get an error dialog saying:

"Could not open location 'file:///home/uno/Desktop'
Details: There was an error parsing the default action command associated with
this location."




How reproducible:
Awlways

Comment 1 Ray Strode [halfline] 2006-03-28 16:14:04 UTC
Works for me...Do you have some non-stock file manager installed (to replace
nautilus?)

Comment 2 Uno Engborg 2006-03-28 17:08:48 UTC
No, nautilus-2.14.0-1.
The only non gnome stuff I have is alacarte-0.8-7.fc5

I have now and then switched to swedish locale, if that could have had any
impact on this.

Comment 3 Ray Strode [halfline] 2006-03-28 17:41:58 UTC
Do you see the problem with a fresh user?

What is the output of 
gconftool-2 -R /desktop/gnome/url-handlers
?

Can you attach the contents of 
/usr/share/applications/defaults.list
and
/usr/share/applications/mimeinfo.cache
?


Comment 4 Uno Engborg 2006-03-30 01:18:46 UTC
Created attachment 127035 [details]
gconftool-2 -R /desktop/gnome/url-handlers

Comment 5 Uno Engborg 2006-03-30 01:19:43 UTC
Created attachment 127036 [details]
/usr/share/applications/defaults.list

Comment 6 Uno Engborg 2006-03-30 01:22:45 UTC
Created attachment 127037 [details]
 /usr/share/applications/mimeinfo.cache

Comment 7 Ray Strode [halfline] 2006-03-30 04:07:55 UTC
Hi, the entry in mimeinfo.cache that starts with
inode/directory=fedora-kdesvn.desktop looks suspicious.

Does /usr/share/applications/fedora-kdesvn.desktop have 
OnlyShowIn=KDE; 
in it anywhere?  If not, can you add the line to the bottom of the file and then
run update-desktop-database (as root).

Does that fix your problem?  If not, does (temporarily) uninstalling kdesvn fix
your problem?

Comment 8 Uno Engborg 2006-03-31 00:03:36 UTC
Adding OnlyShowIn=KDE and update-desktop-database sort of fixes the problem, in
that I then can open the Desktop folder from the places menu. But the side
effect is off course that I no longer have kdesvn in my Gnome Menu it's not even
there to add back with Alacarte. Shouldn't that be possible?





Comment 9 Ray Strode [halfline] 2006-03-31 00:29:23 UTC
Hi,

What if you add

inode/directory=gnome-nautilus-folder-handler.desktop

to /usr/share/applications/defaults.list

? Do you get to keep your menu entry and things work?

Comment 10 Uno Engborg 2006-03-31 01:24:08 UTC
Yes, that seam to work.
Thanks!

Comment 11 Ray Strode [halfline] 2006-03-31 02:49:11 UTC
Hi,

Thanks for testing.  Retitling bug report and changing components.

Comment 12 Matthias Clasen 2006-07-26 17:19:27 UTC
Fixed in 0.18-2

Comment 13 Alexander Larsson 2006-08-14 11:16:57 UTC
*** Bug 188464 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.