Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 186689 - ATI driver rejects any resolutions higher than 640x480
Summary: ATI driver rejects any resolutions higher than 640x480
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-03-25 13:13 UTC by Walery Studennikov
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-09-29 21:03:37 UTC


Attachments (Terms of Use)
Xorg log file (deleted)
2006-04-30 04:35 UTC, Steve Bergman
no flags Details
xorg config file (deleted)
2006-04-30 04:39 UTC, Steve Bergman
no flags Details
Anaconda produced /tmp/Xconfig.test (deleted)
2006-06-20 04:44 UTC, Emmanuel Galanos
no flags Details
X log (deleted)
2006-06-20 04:45 UTC, Emmanuel Galanos
no flags Details
lspci -vv output (deleted)
2006-06-20 04:46 UTC, Emmanuel Galanos
no flags Details

Description Walery Studennikov 2006-03-25 13:13:16 UTC
Description of problem:


Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.5.7.3-4.i386.rpm

How reproducible:
Set "ati" or "radeon" friver in xorg.conf.
Set any display resolution in xorg.conf.
X starts in 640x480 resolution an regardless resolution you specify in corg.conf.

Steps to Reproduce:
1. Set "ati" or "radeon" friver in xorg.conf.
2. Set any display resolution in xorg.conf.
3. run startx
  
Actual results:
X starts in 640x480 resolution an regardless resolution you specify in corg.conf
X reports warnings in log file: "hsync out of range" for ALL modes higher than
640x480.
But my "HorizSync" parameter specified correctly in xorg.conf.


Expected results:
X should start in resolution you specify in xorg.conf

Additional info:
My card is ATI X700

Comment 1 Pti-seb 2006-03-27 11:13:39 UTC
I have the same bug with my ATI X800 XL card when i use radeon driver. I use FC5
with x86_64 architecture.


Comment 2 Simon 2006-04-06 11:27:04 UTC
I can confirm that issue.

I have an AMD x2 3800+, 2048MB RAM, ATI X800GTO (PCI-E) and a DELL 2405FWP.

I am able to install FC5 in text mode but after starting X only the 640x480
resolution is possible and if I start under settings the "Display" the whole
system freeze...

Comment 3 Simon 2006-04-11 10:21:47 UTC
@Walery

Can you change the priority into "high"? I think this is a not a small issue, I
can't work with that crappy resolution.

Comment 4 Steve Bergman 2006-04-30 04:29:25 UTC
I have a radeon 9100 and am seeing the same problem.  I can take the xorg.conf
that is working just fine in my CentOS 4.3 partition and move it to /etc/X11/
and I still get 640x480 only.

Comment 5 Steve Bergman 2006-04-30 04:35:31 UTC
Created attachment 128404 [details]
Xorg log file

Comment 6 Steve Bergman 2006-04-30 04:39:24 UTC
Created attachment 128405 [details]
xorg config file

Comment 7 Emmanuel Galanos 2006-06-20 04:43:17 UTC
I have also seen this problem when attempting to install FC 5. Only the top
left corner (up to the bubbles) of the installation screen was visible. I had
to switch to text mode install.

Installing IA32 version with a PCIE Radeon X700 connected to a 1680x1050 LCD.

Logs attached.

Comment 8 Emmanuel Galanos 2006-06-20 04:44:48 UTC
Created attachment 131168 [details]
Anaconda produced /tmp/Xconfig.test

Comment 9 Emmanuel Galanos 2006-06-20 04:45:29 UTC
Created attachment 131169 [details]
X log

Comment 10 Emmanuel Galanos 2006-06-20 04:46:05 UTC
Created attachment 131170 [details]
lspci -vv output

Comment 11 Steve Bergman 2006-06-24 14:05:16 UTC
It's been 3 months and plenty of people have submitted diagnostic info.

And those who have taken the time to report the bug and provide diagnostic info
have heard *zilch*.  The bug has not even been assigned to an actual person.

This tell's me about as much about Fedora Core as I need to know.

Comment 12 Simon 2006-06-25 10:13:57 UTC
(In reply to comment #11)
> It's been 3 months and plenty of people have submitted diagnostic info.
> 
> And those who have taken the time to report the bug and provide diagnostic info
> have heard *zilch*.  The bug has not even been assigned to an actual person.
> 
> This tell's me about as much about Fedora Core as I need to know.

I have migrated to Ubuntu 6.06 and with this
[https://help.ubuntu.com/community/BinaryDriverHowto/ATI] instruction and an
additional [dpkg-reconfigure xserver-xorg] I could run my x1800XT without any
problem. Fedora seems to me like a big half-baked alpha testing project which
don't have any ambition to solve such problem because you should buy later redhat...



Comment 14 Mike A. Harris 2006-07-24 08:53:44 UTC
Does this problem still occur with X fully updated to rawhide, including
the server and ati driver?

Comment 15 Henrik Wiberg 2006-08-11 08:56:07 UTC
This problem still occurs after a software update.
F.Y.I: The same problem exists in SUSE 10.1

Comment 16 Adam Jackson 2006-08-18 01:42:42 UTC
This is, in fact, an upstream Radeon bug.  It's detecting more devices attached
than there really are, and since clone mode is the default and it can't get DDC
info from the (unconnected) second display, it forces you to a range of
resolutions that are likely to be safe, which means 640x480.

Switching distros is unlikely to be an effective long-term solution, since
they'll just have this same problem when they upgrade to a sufficiently recent
radeon driver.

I'm working on it though.

Comment 17 Adam Jackson 2006-09-29 21:03:37 UTC
This should be fixed as of xorg-x11-drv-ati 6.6.2-2.  Please test, and reopen if
this is still an issue for you.


Note You need to log in before you can comment on or make changes to this bug.