Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 186396 - Anaconda grabs __db.000 lock on host not target under Kadischi
Summary: Anaconda grabs __db.000 lock on host not target under Kadischi
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-03-23 11:28 UTC by Jasper O. Hartline
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-09-06 12:47:42 UTC


Attachments (Terms of Use)

Description Jasper O. Hartline 2006-03-23 11:28:23 UTC
Description of problem:
While running Anaconda under Kadischi, RPM transactions aren't possible on the
host. lsof shows that Anaconda grabs all required locks in the target system 
__db.00{1,2,3} but __db.000 is locked on the host, rather than the target.

Not exactly sure this is supposed to be this way, it could be perhaps.
It could also be a falling out between Anaconda and any changes between it and
the RPM Python modules. I didn't look into it too deep.

It is my understanding Anaconda should only grab those locks in which are
intended under the --rootpath specified. This is how Kadischi invokes Anaconda
also. Thanks.

Version-Release number of selected component (if applicable):
anaconda-11.0.5-1

How reproducible:
Run Anaconda under Kadischi, try an RPM transaction on the host.

Steps to Reproduce:
1. RPM transactions
2.
3.
  
Actual results:
RPM transaction on the host were not possible during running of Anaconda and
Kadischi. 

Expected results:
Should perhaps be able to install something, anything say with rpm or yum while
using Kadischi with Anaconda.

Additional info:
I can provide a brief lsof text if needed, Anaconda grabs the locks mentioned
above in the target, but grabs the __db.000 lock on the host.

Comment 1 Curtis Doty 2006-07-04 04:09:37 UTC
I have a separate issue with anaconda holding locks on
/var/lib/rpm/__db.00{1,2,3}. In %post I would like to briefly unmount /var but
cannot due to these locks. I think this started around core 4 or core 5.

Comment 2 Jasper O. Hartline 2006-09-06 12:25:49 UTC
This issue seems to have been fixed. While using the latest RAWHIDE as of today
September 6th 2006, I can successfully run Kadischi and install some package
with Yum at the same time. 

Thanks.


Note You need to log in before you can comment on or make changes to this bug.