Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 186328 - Disk Busy error during installation, after "About to Install" screen
Summary: Disk Busy error during installation, after "About to Install" screen
Keywords:
Status: CLOSED DUPLICATE of bug 160693
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-22 22:28 UTC by Richard Chaffer
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-03-24 12:24:22 UTC


Attachments (Terms of Use)
Partition Tables of my two harddisks (deleted)
2006-03-22 22:28 UTC, Richard Chaffer
no flags Details

Description Richard Chaffer 2006-03-22 22:28:40 UTC
Description of problem: When attempting to install Fedora Core 4 from DVD,
installation halts on the "About to Install" screen, with the "Disk Busy" errors
given below (see actual results).


Version-Release number of selected component (if applicable): Unsure of anaconda
version


How reproducible:
Please find attached my harddisk partition configuration, which may assist you
in reproducing this error.


Steps to Reproduce:
1. Conduct installation normally up to repartitioning.
2. Select manual partition.
3. Set the mount point for hdb5 to / (root) and flag it for formatting (because
you have no choice).
4. Do not install a bootloader.
5. Continue, leaving all defaults.
6. On "About to install" screen, select install.
  
Actual results:
Almost instantly, an error is displayed: "/dev/hdb5 - Device or resource busy.
This means, Linux won't know about any changes you made to /dev/hdb5 until you
reboot - so you shouldn't mount it or use it in any way before rebooting."
Followed by a string of python errors, that start regarding (what I suppose are)
next button procedures, and culminate in Harddisk-related functions, followed by
"ERROR: error: Error: /dev/hdb5 - Device or resource..." etc as above.

Expected results:
No error message;
Repartitioning, and Installation of FC4.

Additional info:
I attempted to save the error output to floppy disk, however upon checking the
same disk (from within Ubuntu), found there was no file present (hidden or
otherwise).

Comment 1 Richard Chaffer 2006-03-22 22:28:40 UTC
Created attachment 126513 [details]
Partition Tables of my two harddisks

Comment 2 Richard Chaffer 2006-03-24 12:24:22 UTC

*** This bug has been marked as a duplicate of 160693 ***


Note You need to log in before you can comment on or make changes to this bug.