Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 186307 - RHEL3U7 fails installation using RSA(2).
Summary: RHEL3U7 fails installation using RSA(2).
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel
Version: 3.0
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact: Brian Brock
Depends On:
Blocks: RHEL3U8CanFix
TreeView+ depends on / blocked
Reported: 2006-03-22 20:15 UTC by Konrad Rzeszutek
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version: RHSA-2006-0437
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2006-07-20 13:59:45 UTC
Target Upstream Version:

Attachments (Terms of Use)
Output from /proc/bus/usb/devices (deleted)
2006-03-22 20:15 UTC, Konrad Rzeszutek
no flags Details
Candidate #1 - Per-adapter max_sectors (deleted)
2006-04-18 09:15 UTC, Pete Zaitcev
no flags Details | Diff
Patch which was posted for review. Re-worked from Pete's. Added extra ProductIDs (deleted)
2006-04-19 04:15 UTC, Konrad Rzeszutek
no flags Details | Diff

System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2006:0437 normal SHIPPED_LIVE Important: Updated kernel packages for Red Hat Enterprise Linux 3 Update 8 2006-07-20 13:11:00 UTC

Description Konrad Rzeszutek 2006-03-22 20:15:02 UTC
Description of problem:
When installaing RHEL3U7 remotly using the RSA(2) adapter the installation fails
- during the check media and also when installing packages. 

Version-Release number of selected component (if applicable):

How reproducible:


Steps to Reproduce:
1). From a remote host bring up a Java enabled browser to the RSA(2) device.
Select the Remote Control. In the new window click on the "Select file" to
select the RHEL3 U7 ISO image. Hit "Mount Drive"

2). Boot up the machine

3). Go through the steps of installing RHEL3 U7 and see it fail during media
check or during installation (packages are not read correctly)

Actual results:

Installation fails.

Expected results:
Installation succceeds.

Additional info:

With further discovery using an USB analyzer tool it became evident that
the RSA(2) emulates the USB CDROM. And since network latency is an issue here,
the RSA(2) adapter returns an error when it cannot fulfill the request for 63
sectors. It has no problems when the request is for 60 sectors. 

There are two ways of fixing this: Make the RSA firmware return a different
error that would signal "timeout" and not "error" condition (in discussion) and
blacklist the RSA(2) adapter to set the request to the max of 60 sectors.

For the second purpose I am attaching an output from /proc/bus/usb/devices.

I am getting confirmation from the RSA folks about there being only
one type of VendorID and ProductID.

Comment 1 Konrad Rzeszutek 2006-03-22 20:15:02 UTC
Created attachment 126501 [details]
Output from /proc/bus/usb/devices

Comment 2 Konrad Rzeszutek 2006-03-23 13:52:54 UTC

The ID will be either:

depending on which version of RSA(2) hardware is used.

Comment 5 Pete Zaitcev 2006-04-18 09:15:15 UTC
Created attachment 127905 [details]
Candidate #1 - Per-adapter max_sectors

Comment 7 Konrad Rzeszutek 2006-04-19 03:30:23 UTC
Patch posted for review.

Comment 8 Konrad Rzeszutek 2006-04-19 04:15:37 UTC
Created attachment 127969 [details]
Patch which was posted for review. Re-worked from Pete's. Added extra ProductIDs

Comment 9 Ernie Petrides 2006-04-23 08:30:53 UTC
Reverting last reassignment.  Looks like patch was Pete's after all.

Konrad, when you get a chance, please ack Pete's patch on rhkernel-list
(and I guess you should explain that you posted it on Pete's behalf after
verifying the fix -- maybe you'll be the first person to ack a patch that
he/she has posted).  :)

Thanks.  -ernie

Comment 10 Konrad Rzeszutek 2006-04-25 15:53:22 UTC

I am not allowed to post ACKs (as I am a "contractor" and not an employee). I
will solicit other people for ACKs and also post an explanation.

Comment 11 Ernie Petrides 2006-04-25 22:07:54 UTC
Hi, Konrad.  I give you permission to "ack" any patch on rhkernel-list
that you feel competent enough to review (on technical grounds).  If
anyone says you can't say "ack", then you can say that you have reviewed
the code changes and support them on their technical merits.

In any case, I'm considering the patch to be yours, so I'll count PeteZ's
ack (as the 2nd one), and I'm queuing the patch for tonight's build.

Cheers.  -ernie

Comment 12 Ernie Petrides 2006-04-26 04:20:13 UTC
A fix for this problem has just been committed to the RHEL3 U8
patch pool this evening (in kernel version 2.4.21-41.EL).

Comment 15 Red Hat Bugzilla 2006-07-20 13:59:45 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.