Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 185692 - avahi-sharp installs into wrong location for x86-64
Summary: avahi-sharp installs into wrong location for x86-64
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: avahi
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Martin Bacovsky
QA Contact:
URL:
Whiteboard:
: 227824 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-16 22:16 UTC by David Zeuthen
Modified: 2013-03-06 03:45 UTC (History)
7 users (show)

Fixed In Version: avahi-0.6.16-4.fc6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-11 10:44:15 UTC


Attachments (Terms of Use)
Revert changing the mono directory to /usr/lib (deleted)
2006-12-19 18:49 UTC, Toshio Kuratomi
no flags Details | Diff

Description David Zeuthen 2006-03-16 22:16:49 UTC
Description of problem:

Mono stuff needs to be installed into %prefix/lib instead of %libdir - yes, this
sounds odd but this is how mono right now works. See also bug 185690. 

Without this e.g. Banshee from Extras breaks.

Version-Release number of selected component (if applicable):

Rawhide - also applicable to FC5

Comment 1 Jason Vas Dias 2006-03-16 22:48:35 UTC
Thanks, David - fixed with avahi-0.6.9-6, now built into rawhide.


Comment 2 David Zeuthen 2006-03-17 16:19:44 UTC
Thanks Jason - did you send the patch upstream? It probably should be upstream
as bug 185690 now seems to indicate that upstream mono indeed uses %prefix/lib
instead of %libdir

Comment 3 Fedora Update System 2006-03-21 03:31:08 UTC
avahi-0.6.9-6 has been pushed for FC5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Comment 4 Andy Kwong 2006-05-01 14:39:51 UTC
pkg-config is returning /usr/lib64 in the linker flags for package
"avahi-sharp". This is due to the libdir being still set to /usr/lib64 in the
following file.

/usr/lib64/pkgconfig/avahi-sharp.pc

The problem is that when we are compiling applications that uses avahi-sharp
(such as the banshee rpm), the build process fails as it is trying to use
/usr/lib64/mono/avahi-sharp.

Settins the libdir back to /usr/lib in the above file allows for banshee to be
built correctly.

Comment 5 Ilya Konstantinov 2006-09-18 12:29:29 UTC
The Banshee x86-64 RPM found in Rawhide looks for avahi-sharp.dll in lib64. I
didn't build it myself, so I don't know what it looks for at build time.
However, once built, its run with the 64-bit Mono runtime, which expects to find
its DLLs in lib64. I don't think that banshee.exe itself has any preference for
lib vs. lib64; it simply requests "avahi-sharp" from the runtime.

Comment 6 Michel Alexandre Salim 2006-11-02 00:51:34 UTC
Yes. The 0.10.12 version in FE6 somehow works despite avahi being installed in
/usr/lib, but the 0.11.2 version I compiled from source would fail in trying to
load avahi unless I symlink /usr/lib/mono/gac/avahi-sharp to
/usr/lib64/mono/gac/avahi-sharp

Comment 7 Dan Berger 2006-11-24 16:33:48 UTC
For what it's worth, the current shipping avahi-sharp RPM and the current
shipping banshee RPM for FC6 x86_64 don't play nice together.

Rebuilding from spec and commenting out the following lines solves the problem,
but may be the "Wrong Thing (tm)".

# Fix avahi-sharp default installation into /usr/lib64 on x86_64:
if [ ! -e $RPM_BUILD_ROOT/%{_prefix}/lib/mono ] && \
   [ -e  $RPM_BUILD_ROOT/%{_libdir}/mono ]; then
   mv -f $RPM_BUILD_ROOT/%{_libdir}/mono $RPM_BUILD_ROOT/%{_prefix}/lib; 
fi


Comment 8 Toshio Kuratomi 2006-12-19 18:38:37 UTC
If you read the ending of Bug #185690 the placement of mono's gac changed
towards the end of FC6's development cycle.  So avahi's original behaviour --
placing the mono assemblies in %{_libdir} is correct for FC6+.

Will attach a patch to fix this.

Comment 9 Toshio Kuratomi 2006-12-19 18:49:39 UTC
Created attachment 144030 [details]
Revert changing the mono directory to /usr/lib

Reverts cvs changes 1.46-1.49, 0.6.9-6: Move mono assemblies from %{_libdir} to
/usr/lib in the spec file.

Reverts half of cvs change 1.53, 0.6.9-9.FC6: patching the pkgconfig file to
use /usr/lib instead of %{_libdir} (The other half of this was removed earlier
as it was upstreamed.)

Comment 10 Michel Alexandre Salim 2007-02-20 19:46:42 UTC
This bug should probably be closed -- avahi now installs in %{libdir} and
Banshee 0.11.x builds against it fine (in Rawhide)

Comment 11 Paul Howarth 2007-02-20 21:03:32 UTC
It's still broken in FC6, despite more than one update having been issued since
the bug was raised...

Comment 12 Martin Bacovsky 2007-04-11 10:44:15 UTC
Finally this issue should be fixed in fc6 in avahi-sharp-0.6.16-4.fc6

Comment 13 Martin Bacovsky 2007-04-11 11:42:15 UTC
*** Bug 227824 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.