Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 185557 - CF card (detected as pcmcia) on Fujitsu Lifebook P Series (P1510D) gets labeled as not removable by the kernel.
Summary: CF card (detected as pcmcia) on Fujitsu Lifebook P Series (P1510D) gets label...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hal
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
: 184471 (view as bug list)
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2006-03-15 19:54 UTC by Suzanne Hillman
Modified: 2013-03-13 04:50 UTC (History)
5 users (show)

Fixed In Version: hal-0.5.7-10
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-31 20:21:31 UTC


Attachments (Terms of Use)
lshal output (deleted)
2006-03-15 22:03 UTC, Suzanne Hillman
no flags Details
lshal output with CF card inserted (deleted)
2006-03-16 15:18 UTC, Suzanne Hillman
no flags Details

Description Suzanne Hillman 2006-03-15 19:54:13 UTC
Description of problem:
CF cards put into the CF slot (detected as pcmcia) on Fujitsu Lifebook P Series
(P1510D) gets labeled as not removable by the kernel.

The card is detected as ide1, and set to hdc1. When one runs "cat
/sys/block/hdc/removable", the result is 0, even though the card is, in fact, a
CF card and definitely removable.

Because of being set as not removable, hal can't mount it, and gives an error
about "Cannot mount volume, You are not privileged to mount the volume 'LEXAR
MEDIA'."

This is fresh from the packaging, and has not had anything done to it at this point.

Version-Release number of selected component (if applicable):
kernel-2.6.15-1.2025_FC5

How reproducible:
Always

Steps to Reproduce:
1. Obtain a Fujitsu Lifebook P Series (P1510D) installed with rawhide from last week
2. Insert the CF card into the CF slot
  
Actual results:
Get the error about not being privileged.

Expected results:
Should be able to be mounted by hal.

Additional info:
(from /var/log/messages)
Mar 15 14:12:42 dhcp83-18 kernel: pccard: PCMCIA card inserted into slot 0
Mar 15 14:12:42 dhcp83-18 kernel: pcmcia: registering new device pcmcia0.0
Mar 15 14:12:43 dhcp83-18 kernel: hdc: LEXAR ATA FLASH, CFA DISK drive
Mar 15 14:12:43 dhcp83-18 kernel: ide1 at 0x3100-0x3107,0x310e on irq 3
Mar 15 14:12:43 dhcp83-18 kernel: hdc: max request size: 128KiB
Mar 15 14:12:43 dhcp83-18 kernel: hdc: 1001952 sectors (512 MB) w/1KiB
Cache, CHS=994/16/63
Mar 15 14:12:43 dhcp83-18 kernel:  hdc: hdc1
Mar 15 14:12:43 dhcp83-18 kernel: ide-cs: hdc: Vcc = 3.3, Vpp = 0.0

(from dmesg)
pccard: PCMCIA card inserted into slot 0
pcmcia: registering new device pcmcia0.0
Probing IDE interface ide1...
hdc: LEXAR ATA FLASH, CFA DISK drive
ide1 at 0x3100-0x3107,0x310e on irq 3
hdc: max request size: 128KiB
hdc: 1001952 sectors (512 MB) w/1KiB Cache, CHS=994/16/63
 hdc: hdc1
ide-cs: hdc: Vcc = 3.3, Vpp = 0.0

Comment 1 David Zeuthen 2006-03-15 20:35:43 UTC
Hi, please also attach the output from 'lshal'. Thanks.

Comment 2 Suzanne Hillman 2006-03-15 22:03:21 UTC
Created attachment 126174 [details]
lshal output

Comment 3 David Zeuthen 2006-03-15 22:12:51 UTC
It looks like you captured the output in comment 2 without the CF card inserted.
Is it possible to get lshal output when the card is inserted? Thanks.

Comment 4 Pete Zaitcev 2006-03-16 00:01:36 UTC
CF card is not a removable media, strictly speaking. The device gets
removed together with the media, so it's more similar to an IDE controller
in a PCI hotplug slot. But the difference is rather academic.
If David Zeuten can find a way to work around the issue easily, he'll
save the day. But if not, I suppose we can force "removable" for
ide_cs...

Marking NEEDINFO because correct lshal output is needed.


Comment 5 Suzanne Hillman 2006-03-16 15:14:11 UTC
Oops! Sorry. Yeah, I was a bit out of it yesterday, apparently.

Will attach lshal _with_ the CF card plugged in in a few moments.

Comment 6 Suzanne Hillman 2006-03-16 15:18:32 UTC
Created attachment 126225 [details]
lshal output with CF card inserted

Comment 7 David Zeuthen 2006-03-23 17:00:34 UTC
I suppose I could fix this (special case for the ide_cs driver) in the next hal
release - not sure it will make FC5 since the next hal release will grow a
rather large PolicyKit dependency. But the fix should be easy to backport though.. 

Btw, I have this hardware too and I'm able to reproduce it.

I'm reassigning this bug to the hal component then.


Comment 8 David Zeuthen 2006-03-26 20:17:06 UTC
*** Bug 184471 has been marked as a duplicate of this bug. ***

Comment 9 David Zeuthen 2006-03-26 20:54:12 UTC
Hi, please try the RPM's from here

 http://people.freedesktop.org/~david/rh185557/

Thanks,
David

Comment 10 David Zeuthen 2006-03-26 20:58:37 UTC
Btw, these are the changes against hal CVS HEAD - the patch also applies to
0.5.7 so we should be good to put this in both Rawhide and FC5 updates

2006-03-26  David Zeuthen  <davidz@redhat.com>

        Fix for RH bug #185557

        * hald/linux2/blockdev.c (hotplug_event_begin_add_blockdev): Introduce
        "pcmcia" as a value storage.bus and mark devices of this bus as being
        hotpluggable

        * fdi/information/10freedesktop/10-usb-card-readers.fdi: When
        storage.bus="pcmcia" mark all drives with "FLASH" in the model
        string as having drive_type="compact_flash"


Comment 11 David Zeuthen 2006-03-26 21:05:37 UTC
Btw, you want to reboot your system after upgrading hal

Comment 12 Brian Millett 2006-03-29 13:51:48 UTC
Ok, so where is it?  Is this coming soon?

Thnaks.

Comment 13 David Zeuthen 2006-03-29 16:55:22 UTC
How about right here

 http://people.freedesktop.org/~david/rh185557/

as mentioned in comment 9 :-)

Comment 14 David Zeuthen 2006-03-30 16:09:28 UTC
Ping. Please let me know if the packages work for you so I can close this bug
and push packages to Rawhide and FC5.

Thanks, David

Comment 15 Suzanne Hillman 2006-03-30 16:42:13 UTC
Sorry. Was out sick, so had no access to the laptop in question. Will check today.

Comment 16 Suzanne Hillman 2006-03-30 18:04:18 UTC
The new packages does fix the problem. Thank you!

Not entirely sure how one handles things being fixed in FC, though, since there
are not AFAIK errata. What do I need to do now, to indicate that I agree that it
works?

Comment 17 David Zeuthen 2006-03-31 18:38:41 UTC
Suzanne, thanks for testing. 

I'm going to put this in Rawhide and FC5 updates.. will probably take a little
while as I want to include fixes for bug 173085 and bug 185527 too.


Comment 18 David Zeuthen 2006-05-19 14:59:37 UTC
The actual patch is here (extracted from the SRPM in comment 13)

 http://people.freedesktop.org/~david/rh185557/hal-0.5.7-pcmcia-readers.patch

I've built this patch into rawhide as hal-0.5.7-10. 

John, can you put this patch through as a FC5 update please? Thanks.



Note You need to log in before you can comment on or make changes to this bug.