Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 185352 - python_sitelib on RHEL3 and RHEL4 differs
Summary: python_sitelib on RHEL3 and RHEL4 differs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: python
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mihai Ibanescu
QA Contact: Brock Organ
URL:
Whiteboard:
: 185103 (view as bug list)
Depends On:
Blocks: RHEL3U8CanFix
TreeView+ depends on / blocked
 
Reported: 2006-03-13 22:22 UTC by Joshua Jensen
Modified: 2007-11-30 22:07 UTC (History)
3 users (show)

Fixed In Version: RHBA-2006-0442
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-07-20 15:17:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0442 normal SHIPPED_LIVE python bug fix update 2006-07-19 20:35:00 UTC

Description Joshua Jensen 2006-03-13 22:22:34 UTC
Description of problem:

python_sitelib on RHEL3 and RHEL4 differs

Run this command on RHEL4 and RHEL3, both x86_64:

python -c 'from distutils import sysconfig; print sysconfig.get_python_lib(),
sysconfig.get_python_lib(1)'

The first string is the python_sitearch, and the second string is that of
python_sitelib.

On RHEL3 x86_64:
$ python -c 'from distutils import sysconfig; print sysconfig.get_python_lib(),
sysconfig.get_python_lib(1)'

/usr/lib64/python2.2/site-packages /usr/lib64/python2.2/site-packages


On RHEL4 x86_64:
$ python -c 'from distutils import sysconfig; print sysconfig.get_python_lib(),
sysconfig.get_python_lib(1)'

/usr/lib/python2.3/site-packages /usr/lib64/python2.3/site-packages

Why the differences?  This problem seems to keep several x86_64 python-related
packages from building on RHEL3.

Version-Release number of selected component (if applicable):

RHEL3 and RHEL4 x86_64, any update level

Comment 1 Dag Wieers 2006-03-14 06:18:59 UTC
I have seen this as well. All noarch x86_64 packages fail to build, and some
mixed noarch/arch packages (that both use python_sitelib and python_sitearch)
fail to build as well (python-elementree comes to mind).

FC2 is also affected by this problem. (as I do not have a RH9 or FC1 x86_64)

[root@lisse rpms]# dar-exec "python -c 'from distutils import sysconfig; print
sysconfig.get_python_lib(), sysconfig.get_python_lib(1)'"
= Executing "python -c 'from distutils import sysconfig; print
sysconfig.get_python_lib(), sysconfig.get_python_lib(1)'" for el4a.
/usr/lib/python2.3/site-packages /usr/lib64/python2.3/site-packages
= Executing "python -c 'from distutils import sysconfig; print
sysconfig.get_python_lib(), sysconfig.get_python_lib(1)'" for el4i.
/usr/lib/python2.3/site-packages /usr/lib/python2.3/site-packages
= Executing "python -c 'from distutils import sysconfig; print
sysconfig.get_python_lib(), sysconfig.get_python_lib(1)'" for fc3a.
/usr/lib/python2.3/site-packages /usr/lib64/python2.3/site-packages
= Executing "python -c 'from distutils import sysconfig; print
sysconfig.get_python_lib(), sysconfig.get_python_lib(1)'" for fc3i.
/usr/lib/python2.3/site-packages /usr/lib/python2.3/site-packages
= Executing "python -c 'from distutils import sysconfig; print
sysconfig.get_python_lib(), sysconfig.get_python_lib(1)'" for fc2a.
/usr/lib64/python2.3/site-packages /usr/lib64/python2.3/site-packages
= Executing "python -c 'from distutils import sysconfig; print
sysconfig.get_python_lib(), sysconfig.get_python_lib(1)'" for fc2i.
/usr/lib/python2.3/site-packages /usr/lib/python2.3/site-packages
= Executing "python -c 'from distutils import sysconfig; print
sysconfig.get_python_lib(), sysconfig.get_python_lib(1)'" for fc1i.
/usr/lib/python2.2/site-packages /usr/lib/python2.2/site-packages
= Executing "python -c 'from distutils import sysconfig; print
sysconfig.get_python_lib(), sysconfig.get_python_lib(1)'" for el3a.
/usr/lib64/python2.2/site-packages /usr/lib64/python2.2/site-packages
= Executing "python -c 'from distutils import sysconfig; print
sysconfig.get_python_lib(), sysconfig.get_python_lib(1)'" for el3i.
/usr/lib/python2.2/site-packages /usr/lib/python2.2/site-packages
= Executing "python -c 'from distutils import sysconfig; print
sysconfig.get_python_lib(), sysconfig.get_python_lib(1)'" for rh9i.
/usr/lib/python2.2/site-packages /usr/lib/python2.2/site-packages

So I bet everything prior to python 2.3.4 is affected.

Here is a diff between EL3 and EL4 for distutils/sysconfig.py
     if os.name == "posix":
+        if plat_specific or standard_lib:
+            lib = "lib64"
+        else:
+            lib = "lib"
         libpython = os.path.join(prefix,
-                                 "lib64", "python" + sys.version[:3])
+                                 lib, "python" + get_python_version())

This makes it impossible to cross-build python packages.

Comment 2 Mihai Ibanescu 2006-03-14 13:17:58 UTC
I guess we didn't catch these when we did the work for multilib.

Comment 3 Dag Wieers 2006-04-06 00:42:06 UTC
The recent EL3 U7 python update would have been a good opportunity to fix this.
Is it planned to be fixed in the next EL3 python update ? Or at least queued
when there is a real need to release a python update ?

Comment 4 Mihai Ibanescu 2006-04-07 21:13:30 UTC
Dag, we are working on getting a schedule for this bug. It could not get into
U7, it was too late for that.

Comment 7 Mihai Ibanescu 2006-05-01 16:37:52 UTC
Built python-2.2.3-6.3 with a fix.

Comment 11 Red Hat Bugzilla 2006-07-20 15:17:47 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0442.html


Comment 12 Jeremy Katz 2006-12-20 23:23:31 UTC
*** Bug 185103 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.