Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 185186 - Pup (Yum?) doesn't handle disk full situation.
Summary: Pup (Yum?) doesn't handle disk full situation.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-03-11 11:38 UTC by Gilboa Davara
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-08-10 19:09:00 UTC


Attachments (Terms of Use)

Description Gilboa Davara 2006-03-11 11:38:23 UTC
Description of problem:
When upgrading a machine with limited disk space, if pup (or actually yum)
manages to download all the required packages, pup does not handle disk-full
errors during the package installation itself, nor does it report that any error
occurred.
Once pup finished updating the machine it just closed down (crashed?).
Thinking the installation succeeded, I proceeded to reboot the machine but the
the reboot attempt failed. 
Booting into CD rescue mode, I determined that the main root disk was full and
that yum failed to install the 2038 kernel initrd image leaving the machine in
limbo mode.
Sadly enough, due to reasons beyond my control I was forced to delete the master
FC5T3 vmware image so I cannot reproduce the problem. (Getting a meaningful
error code out of yum/pup)

Version-Release number of selected component (if applicable):
Pirut 0.9.10-1

How reproducible:


Steps to Reproduce:
1. Install FC5T3
2. Use pup/yum to determine how much space is required to download the latest
updates. 
3. Full the root partition to "<root size> - <yum download size + 30MB>"
4. Fire up pup, let it update all the packages.
  
Actual results:
1. Pup downloads the packages.
2. Pup install the packages.
3. Pup closes. No error code.

Expected results:
1. Pup should warn user that there's insufficient space to install required
packages.
2. If user insist on installing the updates and yum/rpm fails due to
insufficient disk space, display a meaningful error code.
3. Role back changes?

Additional info:

Comment 1 Jeremy Katz 2006-03-13 18:46:23 UTC
Can you look in the xsession errors to see if there's anything there?  most
things like this are at least trying to be caught, although there could be
something being missed

Comment 2 Gilboa Davara 2006-03-14 08:56:25 UTC
Umm... Sadly enough, I need to reinstall the machine so I can't really reproduce
it now.

Comment 3 Jeremy Katz 2006-09-11 21:20:07 UTC
This is yum -- Seth is working on adding checking into yum itself at which
point, pirut can catch the error and display it usefully for the user.

Comment 4 Matthew Miller 2007-04-06 16:01:21 UTC
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]


Comment 5 Jeremy Katz 2007-08-10 19:09:00 UTC
This should be handled a lot better in Fedora 7 and later


Note You need to log in before you can comment on or make changes to this bug.