Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 185154 - rhythmbox crashes when adding http://leo.am/podcasts/sn
Summary: rhythmbox crashes when adding http://leo.am/podcasts/sn
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: rhythmbox
Version: rawhide
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2006-03-10 22:02 UTC by David Nielsen
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-31 00:01:19 UTC


Attachments (Terms of Use)
Backtrace (deleted)
2006-03-10 22:02 UTC, David Nielsen
no flags Details

Description David Nielsen 2006-03-10 22:02:07 UTC
Description of problem:
When adding http://leo.am/podcasts/sn to the podcast list I get the attached
backtrace.


Version-Release number of selected component (if applicable):
rhythmbox-0.9.3.1-3
gnome-vfs2-2.13.92-3

How reproducible:
100%

Steps to Reproduce:
1. add podcast

  
Actual results:
crash

Expected results:
correctly add podcast

Additional info:

Comment 1 David Nielsen 2006-03-10 22:02:07 UTC
Created attachment 125964 [details]
Backtrace

Comment 2 Matthias Clasen 2006-03-11 14:34:06 UTC
doesn't crash for me.

Comment 3 David Nielsen 2006-03-12 11:51:07 UTC
happens everytime here, even when I clean out .gnome2/rhythmbox

Comment 4 Bastien Nocera 2007-01-30 23:57:22 UTC
Can't reproduce here either. If the problem still occurs with 0.9.7 in rawhide
(or 0.9.6 in FC6), could you please check whether "gnomevfs-cat" crashes for
that URL as well? (as it's crashing trying to read that file:
#0  0x00fb17ca in ne_sock_readline (sock=0x0, buffer=0xb516c228 "", len=8192) at
ne_gnomevfs.c:363
#1  0x00fa5504 in read_response_headers (req=0x8fd5d40) at ne_request.c:1066
#2  0x00fa5b25 in ne_end_request (req=0x8fd5d40) at ne_request.c:1346
#3  0x00fa2d4e in http_transfer_start (handle=0x92d9b70) at http-neon-method.c:2258
#4  0x00fa2fce in do_open (method=0xfb8a20, method_handle=0xb516e318,
uri=0x92ac928, mode=GNOME_VFS_OPEN_NONE, context=0x0) at http-neon-method.c:2368
#5  0x034bd519 in gnome_vfs_open_uri_cancellable (handle=0xb516e3b4,
uri=0x92ac928, open_mode=GNOME_VFS_OPEN_READ, context=0x0) at
gnome-vfs-cancellable-ops.c:57
#6  0x034d4663 in gnome_vfs_open_uri (handle=0xb516e3b4, uri=0x92ac928,
open_mode=GNOME_VFS_OPEN_READ) at gnome-vfs-ops.c:81
#7  0x034d46c1 in gnome_vfs_open (handle=0xb516e3b4, text_uri=0x9270af0
"http://leo.am/podcasts/sn", open_mode=GNOME_VFS_OPEN_READ) at gnome-vfs-ops.c:58
#8  0x034dae62 in gnome_vfs_read_entire_file (uri=0x9270af0
"http://leo.am/podcasts/sn", file_size=0xb516e408, file_contents=0xb516e404) at
gnome-vfs-utils.c:1029
)

Comment 5 David Nielsen 2007-01-31 00:01:19 UTC
Unable to reproduce bug with rhythmbox 0.9.6 and 0.9.7


Note You need to log in before you can comment on or make changes to this bug.