Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 185086 - Filesystems in /etc/fstab that don't exist shouldn't cause install failure
Summary: Filesystems in /etc/fstab that don't exist shouldn't cause install failure
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-03-10 15:02 UTC by Andrew Overholt
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-06-08 15:26:46 UTC


Attachments (Terms of Use)

Description Andrew Overholt 2006-03-10 15:02:25 UTC
Description of problem:
I somehow had an entry in /etc/fstab for /dev/sda2 -> /media/ipod and when I
tried to upgrade from FC4 -> FC5test3, the installation process exited because
/dev/sda2 didn't exist.

Version-Release number of selected component (if applicable):
FC5test3 anaconda

How reproducible:
Always (?)
  
Actual results:
Installation exited.

Expected results:
Installation does not exit.

Additional info:

Comment 1 Jeremy Katz 2006-03-13 18:56:15 UTC
What exactly was the line in /etc/fstab?

Comment 2 Andrew Overholt 2006-03-13 20:01:12 UTC
(In reply to comment #1)
> What exactly was the line in /etc/fstab?

/dev/sda2               /media/ipod             vfat    user    1 1


Comment 3 Jeremy Katz 2006-03-13 20:11:21 UTC
You really probably also want something like noauto in the options.

We'll try to clean up this handling some for FC6 

Comment 4 Jeremy Katz 2006-05-22 18:26:35 UTC
Chris -- note the trickiness in that someone could have, eg, /usr not show up
and we really don't want to do the upgrade then.  Which is why we've kept to the
behavior we currently have.

Comment 5 Chris Lumens 2006-06-08 15:26:46 UTC
We should be doing a better job with this in FC6.  It should now catch error on
non-Linux filesystems and display a warning dialog.  You can then choose to
ignore the warning and upgrade without mounting, or reboot.


Note You need to log in before you can comment on or make changes to this bug.