Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 184395 - pup updates failed with exception No such file or directory
Summary: pup updates failed with exception No such file or directory
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut
Version: 5
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-03-08 15:09 UTC by David Timms
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-08-17 22:37:06 UTC


Attachments (Terms of Use)
exception state log (deleted)
2006-03-08 15:09 UTC, David Timms
no flags Details
second run that had the same exception (deleted)
2006-03-08 15:10 UTC, David Timms
no flags Details

Description David Timms 2006-03-08 15:09:04 UTC
Description of problem:
pup exception shown No such file or directory

Version-Release number of selected component (if applicable):
pirut-1.0.1-1

How reproducible:
twice, but after reboot now it seems OK.

Steps to Reproduce:
1. pup
2. apply
3.
  
Actual results:
exception

Expected results:
completion or nice failure message.

Additional info:
- May have been while mirrors where getting populated with updates !
- After reboot, firefox wont work from gnome icon (starting web browser for ten
seconds then nothing).
- firefox at terminal returns near immediately with no error message.
- rpm -q firefox shows it isn't installed
- rpm -q yum shows it isn't installed either
(is this likely to occur when pup burns ?)
- /var/log/ does not show any activity with firefox / yum 
- It may have been a run where I tested suspend with freecell open, and then
turned the machine on later for resume. The network was up in ifconfig, but no
packets passing. Network icon disable/enable made it work again.

Comment 1 David Timms 2006-03-08 15:09:04 UTC
Created attachment 125804 [details]
exception state log

Comment 2 David Timms 2006-03-08 15:10:58 UTC
Created attachment 125805 [details]
second run that had the same exception

Comment 3 Jeremy Katz 2006-03-13 18:42:18 UTC
It looks like your mirror isn't fully populated and you're using a file:/ path.
 Having repodata updated before everything else is generally a bad idea -- I'd
recommend looking into the --delay-updates and --delete-after flags to rsync to
help avoid things like this.

I'll try to put some more error checking into pirut for this case post-FC5, but
it's a bit pathological :)

Comment 4 Jesse Keating 2006-08-17 22:37:06 UTC
Closing as not an error.  Refile as an RFE for more pathological error checking
if necessary.


Note You need to log in before you can comment on or make changes to this bug.