Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 183989 - Couldn't update FC4 from FC5 Test3, anaconda ran out of disk space.
Summary: Couldn't update FC4 from FC5 Test3, anaconda ran out of disk space.
Keywords:
Status: CLOSED DUPLICATE of bug 183987
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 5
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-04 16:43 UTC by Olen
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-03-04 18:18:55 UTC


Attachments (Terms of Use)

Description Olen 2006-03-04 16:43:44 UTC
Description of problem:
Attempting to update FC4 box (box specs 512 Mb of RAM, 919M of Swap, 180Gb 
disk) from a DVD.
Everything was proceding normal, the previous installaton of FC4 was found and 
selected to be updated.  While preparing the transaction, after a few minutes 
a window appeared and claimed it failed due to being out of disk space. There 
are more than 150Gb free on the physical disk as reported by df -h.  If its a 
disk its referring to, it must be a ram disk.  The physical disk was unchanged 
after this, so FC4 still works.   The popup also said it should let the user 
go back and try again, but I guess that feature hadn't been implemented,so the 
install just exited.

If 512Mb of ram isn't enought to run anaconda/yum for fc5, then I guess this 
isn't a bug.  But I don't know how I'll get updated if thats the case.
I will say that I have a bunch of software installed.  Both Gnome, and KDE, 
and Open Office and much more using yum.

Version-Release number of selected component (if applicable):

FC5 test 3
How reproducible:
I didn't try to reproduce.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Upgrade failed due to out of disk space updating computer with modest amount 
of ram by todays standards, and lots of fc4 packages installed on it.

Expected results:
Ugrade to succeed. 
Additional info:
 Maybe yum should do smaller transactions by groups, such as base first, then 
X11...,  my impression was it tried the whole thing as one huge transaction.  
I guess I can make a local repo out of my DVD, and then do an iterative update 
of the packages for myself.

Comment 1 Chris Lumens 2006-03-04 18:18:55 UTC

*** This bug has been marked as a duplicate of 183987 ***


Note You need to log in before you can comment on or make changes to this bug.