Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 183609 - Split Evolution-dependent parts of Beagle into separate package
Summary: Split Evolution-dependent parts of Beagle into separate package
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: beagle
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL:
Whiteboard:
: 183829 186073 194552 196199 (view as bug list)
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-03-02 09:56 UTC by Mephisto
Modified: 2007-11-30 22:11 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-08-11 12:39:29 UTC


Attachments (Terms of Use)

Description Mephisto 2006-03-02 09:56:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060223 Fedora/1.5.0.1-5 Firefox/1.5.0.1

Description of problem:
The latest version of the beagle package depends on evolution-sharp, which depends on evolution itself. Because of this, i have to install NetworkManager, bind, caching-nameserver, dhcdbd and spamassassin as well. I do not wish to turn my workstation into a full-fledged server. I have no use for dns servers, email filter daemons or dhcp stuff other than the client, nor do i wish to use evolution itself.
Therefore, i would like to see the evolution dependent parts split off into a separate package like evolution-beagle or beagle-evolution.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install to beagle
2.
3.
  

Additional info:

Comment 1 Paul W. Frields 2006-03-24 17:17:47 UTC
*** Bug 186073 has been marked as a duplicate of this bug. ***

Comment 2 Paul W. Frields 2006-03-24 17:20:59 UTC
*** Bug 183829 has been marked as a duplicate of this bug. ***

Comment 3 Alexander Larsson 2006-06-21 08:54:06 UTC
This seems to be because evolution-sharp pulls in a libeshell.so.0 dependency
from evolution, as all other dependencies are from evolution-data-server only. I
wonder what it needs from that.


Comment 4 Alexander Larsson 2006-06-21 09:06:33 UTC
It seems the only access to eshell is in 
glue/mail/e-mail-remote-glue.c:emrg_initialize_session_and_listeners().

Maybe its possible to avoid this? mbarnes, is this possible?


Comment 5 Alexander Larsson 2006-06-21 09:50:37 UTC
*** Bug 194552 has been marked as a duplicate of this bug. ***

Comment 6 Alexander Larsson 2006-06-22 07:41:21 UTC
*** Bug 196199 has been marked as a duplicate of this bug. ***

Comment 7 Matthew Barnes 2006-06-26 14:24:23 UTC
(In reply to comment #4)
> Maybe its possible to avoid this? mbarnes, is this possible?

Investigating...



Comment 8 Matthias Clasen 2006-07-25 16:58:58 UTC
Any update ?

Comment 9 Matthew Barnes 2006-07-25 18:20:45 UTC
Verified what alexl found, but have not yet found a resolution to this.

Comment 10 Matthew Barnes 2006-08-07 14:33:18 UTC
In the course of investigating bug #198191, I discovered that Evolution doesn't
even provide GNOME_Evolution_Shell_findComponent() anymore.  It has been
disabled in shell/Evolution-Shell.idl since before Evolution 2.6.

Trying to find out more information about this, but if what I'm seeing is true
then it should certainly be possible to drop the Evolution dependency.

Comment 11 Matthew Barnes 2006-08-07 15:22:56 UTC
alexl, given the above findings, what do you think is the best course of action?

We can either try to drop the Evolution dependency from Evolution-Sharp
altogether by patching out the already disabled libeshell function, or break the
Evolution-dependent parts of Beagle into a separate package.

One of the upstream guys (varadhan) took a look at this bug and recommended the
latter, although he also commented that he was thinking of dropping the
Evolution dependency from Evolution-Sharp but he needed to talk it over first
with Joe Shaw.  So I guess a third option is to wait and see what upstream does.

Comment 12 Alexander Larsson 2006-08-10 15:29:06 UTC
I talked to joe. They split some beagle backends (like evo) out into a
subpackage. We should probably do that too.


Comment 13 Matthew Barnes 2006-08-10 15:47:34 UTC
Looks like this is now a beagle issue, rather than evolution-sharp.

Changing component to beagle and reassigning.  In the meantime, I'll keep watch
over evolution-sharp's seemingly unnecessary evolution dependency.

Comment 14 Alexander Larsson 2006-08-11 12:39:29 UTC
This is split out in beagle 0.2.7-8


Note You need to log in before you can comment on or make changes to this bug.