Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 183127 - gnome-power-manager crashes when Logitech MX-1000 cordless mouse plugged in
Summary: gnome-power-manager crashes when Logitech MX-1000 cordless mouse plugged in
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-power-manager
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John (J5) Palmieri
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2006-02-26 17:53 UTC by Bernard Johnson
Modified: 2013-03-13 04:49 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-03-02 20:48:43 UTC


Attachments (Terms of Use)
potential fix (deleted)
2006-02-27 12:47 UTC, Richard Hughes
no flags Details | Diff
Package with Richard's proposed fix (deleted)
2006-03-02 17:19 UTC, Ray Strode [halfline]
no flags Details

Description Bernard Johnson 2006-02-26 17:53:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060223 Fedora/1.5.0.1-5 Firefox/1.5.0.1

Description of problem:
When a USB Logitech MX-1000 cordless mouse is plugged in, gnome-power-manager crashes.  I don't know if this is specific to my mouse or not.  Debug output below.

Version-Release number of selected component (if applicable):
gnome-power-manager-2.13.91-1

How reproducible:
Always

Steps to Reproduce:
1. Make sure gpm is running
2. plug in mouse
3.
  

Actual Results:  gpm crashes

Expected Results:  no crash

Additional info:

[bjohnson@localhost ~]$ gnome-power-manager --no-daemon --verbose
[gpm_debug_init] gpm-debug.c:116 (10:45:33):     Debugging enabled
[gpm_hash_new_devices_cache] gpm-hal-monitor.c:694 (10:45:33):   creating cache
[gpm_hal_has_power_management] gpm-hal.c:132 (10:45:33):         Power management type : acpi
[gpm_hash_new_kind_cache] gpm-power.c:1041 (10:45:33):   creating cache
[gpm_hash_new_device_cache] gpm-power.c:1067 (10:45:33):         creating cache
[gpm_hal_is_on_ac] gpm-hal.c:80 (10:45:33):      Couldn't obtain list of ac_adapters
[gpm_power_set_on_ac] gpm-power.c:748 (10:45:33):        emitting ac-state-changed : 1
[gpm_brightness_init] gpm-brightness.c:134 (10:45:33):   No devices of capability laptop_panel
[gpm_manager_init] gpm-manager.c:1515 (10:45:33):        creating new tray icon
[gpm_dpms_set_enabled] gpm-dpms-x11.c:422 (10:45:33):    setting DPMS enabled: 1[x11_sync_server_dpms_settings] gpm-dpms-x11.c:117 (10:45:33):   Syncing DPMS settings enabled=1 timeouts=0 0 0
[x11_sync_server_dpms_settings] gpm-dpms-x11.c:117 (10:45:33):   Syncing DPMS settings enabled=1 timeouts=0 0 0
[gpm_hal_is_laptop] gpm-hal.c:114 (10:45:33):    This machine is not identified as a laptop.system.formfactor is unknown.
[gpm_hal_enable_power_save] gpm-hal.c:289 (10:45:33):    We are not a laptop, so not even trying
[gpm_screensaver_enable_throttle] gpm-screensaver.c:123 (10:45:33):      setThrottleEnabled : 0
[gpm_idle_set_system_timeout] gpm-idle.c:252 (10:45:33):         Setting system idle timeout: 0
[x11_sync_server_dpms_settings] gpm-dpms-x11.c:117 (10:45:33):   Syncing DPMS settings enabled=1 timeouts=0 0 0
[hal_connect_signals] gpm-hal-monitor.c:562 (10:45:33):  Connecting signals to HAL
[hal_connect_signals] gpm-hal-monitor.c:583 (10:45:33):  emitting hal-connected
[coldplug_all] gpm-hal-monitor.c:661 (10:45:33):         coldplugging all devices
[watch_device_add] gpm-hal-monitor.c:427 (10:45:33):     Adding new device to watch: /org/freedesktop/Hal/devices/acpi_PWRF
[watch_device_add] gpm-hal-monitor.c:435 (10:45:33):     Creating proxy for: /org/freedesktop/Hal/devices/acpi_PWRF
[watch_device_add] gpm-hal-monitor.c:427 (10:45:33):     Adding new device to watch: /org/freedesktop/Hal/devices/acpi_PWRB
[watch_device_add] gpm-hal-monitor.c:435 (10:45:33):     Creating proxy for: /org/freedesktop/Hal/devices/acpi_PWRB
[watch_device_add] gpm-hal-monitor.c:427 (10:45:33):     Adding new device to watch: /org/freedesktop/Hal/devices/usb_device_557_2213_noserial_if0_logicaldev_input
[watch_device_add] gpm-hal-monitor.c:435 (10:45:33):     Creating proxy for: /org/freedesktop/Hal/devices/usb_device_557_2213_noserial_if0_logicaldev_input



(MOUSE PLUGGED IN HERE)



[hal_new_capability] gpm-hal-monitor.c:528 (10:45:43):   udi=/org/freedesktop/Hal/devices/usb_device_46d_c50e_noserial, capability=battery
[watch_device_add] gpm-hal-monitor.c:427 (10:45:43):     Adding new device to watch: /org/freedesktop/Hal/devices/usb_device_46d_c50e_noserial
[watch_device_add] gpm-hal-monitor.c:435 (10:45:43):     Creating proxy for: /org/freedesktop/Hal/devices/usb_device_46d_c50e_noserial
[watch_add_battery] gpm-hal-monitor.c:479 (10:45:43):    emitting battery-added : /org/freedesktop/Hal/devices/usb_device_46d_c50e_noserial
[hal_battery_added_cb] gpm-power.c:952 (10:45:43):       Battery Added: /org/freedesktop/Hal/devices/usb_device_46d_c50e_noserial
[add_battery] gpm-power.c:891 (10:45:43):        adding /org/freedesktop/Hal/devices/usb_device_46d_c50e_noserial
[gpm_hal_device_get_int] gpm-hal.c:417 (10:45:43):       Error: No property battery.charge_level.current on device with id /org/freedesktop/Hal/devices/usb_device_46d_c50e_noserial
[gpm_hal_device_get_int] gpm-hal.c:417 (10:45:43):       Error: No property battery.charge_level.percentage on device with id /org/freedesktop/Hal/devices/usb_device_46d_c50e_noserial
[battery_kind_cache_update] gpm-power.c:475 (10:45:43):  1 devices of type Wireless mouse
[battery_kind_cache_update] gpm-power.c:505 (10:45:43):  emitting battery-status-changed : Wireless mouse
[get_stock_id] gpm-manager.c:246 (10:45:43):     Getting stock icon for tray
[tray_icon_update] gpm-manager.c:359 (10:45:43):         Going to use stock id: gnome-power-mouse
[gpm_tray_icon_set_image_from_stock] gpm-tray-icon.c:178 (10:45:43):     Setting icon to gnome-power-mouse
[gpm_power_get_status_summary] gpm-power.c:709 (10:45:44):       tooltip: Computer is running on AC power
Wireless mouse (0%)
[gpm_tray_icon_notify] gpm-tray-icon.c:760 (10:45:44):   doing notify: (null)

** ERROR **: file notifynotification.c: line 330 (notify_notification_new): assertion failed: (summary != NULL)
aborting...

Comment 1 Richard Hughes 2006-02-27 12:47:04 UTC
Created attachment 125313 [details]
potential fix

I spotted a thinko. The attached patch should fix the issue. I'll add this to
CVS now. Can you tell me if this fixes the crash please.

Comment 2 Bernard Johnson 2006-02-27 15:17:08 UTC
I just installed gnome-power-manager-2.13.92-1 from rawhide and it has the same
problems.  I'm assuming that this fix didn't make it into 2.13.92-1.

Can someone add the patch to rawhide?

Comment 3 John (J5) Palmieri 2006-02-27 16:16:56 UTC
Chris can you add this.  Putting on blocker list because it is a crash.

Comment 4 Richard Hughes 2006-02-27 16:23:44 UTC
It's only a crash if you have a CSR mouse, and it's below 5% in charge, and you
insert it after coldplug, so it's somewhat hard to hit :-)


Comment 5 John (J5) Palmieri 2006-02-27 16:34:08 UTC
Yes but it is in a component that runs as root if I am not mistaken.  Any
crashes are serious and should be fixed, expecially if it is reproducible by
simply plugging in a piece of hardware.  Keeping on blocker.

Comment 6 John (J5) Palmieri 2006-02-27 16:35:40 UTC
My mistake.  The crash is happening as the user, not in the callouts.  Ok moving
to target then.

Comment 7 Bernard Johnson 2006-02-27 16:58:49 UTC
Please note, comment #4 is not entirely correct:

1) It does not require an insert.  Simply booting up with the mouse in the
system causes a crash.  I used the insert scenario as it made it easier for me
to get debug messages (ie. running gpm with verbose before I caused the crash).

2) The mouse was not below 5% in charge.  In fact, it was recently charged,
showing 3 of 3 power bars (probably in the 90%+ range.

Comment 8 Ray Strode [halfline] 2006-03-02 17:19:36 UTC
Created attachment 125549 [details]
Package with Richard's proposed fix

Comment 9 Ray Strode [halfline] 2006-03-02 17:20:26 UTC
Hi Bernard,

If you try to install the rpm in attachment 125549 [details] does it fix your problem?

Comment 10 Bernard Johnson 2006-03-02 19:33:55 UTC
This does fix the crash, however, another bug is uncovered now.  I just filed
bug #183679, which would explain why in comment #4, Richard said it would have
to be < 5% charge.

Comment 11 Ray Strode [halfline] 2006-03-02 20:48:43 UTC
Okay, will push the package from attachment 125549 [details] into tomorrow's rawhide.


Note You need to log in before you can comment on or make changes to this bug.