Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 182682 - severe rendering problems when run with Xair
Summary: severe rendering problems when run with Xair
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rdesktop
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Carl Worth
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-02-23 23:03 UTC by Nalin Dahyabhai
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-03-17 00:11:49 UTC


Attachments (Terms of Use)

Description Nalin Dahyabhai 2006-02-23 23:03:04 UTC
Description of problem:
If I switch from Xorg to Xair, attempts to run rdesktop hit major rendering
problems.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xair-1.0.0.0.20060207-5
rdesktop-1.4.1-3.2.1

How reproducible:
Always

Steps to Reproduce:
1. Switch from Xorg to Xair
2. Fire up rdesktop
  
Actual results:
Instead of a login window, I see a blank window with a background color and a
few line segments (bevels?).

Expected results:
The login window presented by the server.

Additional info:
If I turn on the Composite extension under Xorg, it continues to work.
Attempts to capture an image of the rendering corruption fail, suggesting that
it's an error displaying the image rather than garbled image data.

Comment 1 Nalin Dahyabhai 2006-03-17 00:11:49 UTC
It looks like this is fixed in xorg-x11-server-Xorg-1.0.1-8, which I'm told
incorporates the changes which were made in Xair, so I'm closing this.


Note You need to log in before you can comment on or make changes to this bug.