Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 182653 - gnome panel hangs on logout
Summary: gnome panel hangs on logout
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-panel
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2006-02-23 21:06 UTC by Thomas J. Baker
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-03-09 17:59:42 UTC


Attachments (Terms of Use)
gdb attach b a a tb log (deleted)
2006-02-23 21:07 UTC, Thomas J. Baker
no flags Details

Description Thomas J. Baker 2006-02-23 21:06:19 UTC
Description of problem:

gnome-panel seems to hang on logout. If I logout, just the background remains
for 10-20 seconds and then the rest of the logout finishes and gdm is back. If I
then go to a console, I can see that gnome-panel is still running and a few
other things too. I then can't log in again because a new gnome-panel detects a
previously running one.

Version-Release number of selected component (if applicable):

gnome-panel-2.13.91-3, gnome-applets-2.13.4-3

How reproducible:
Everytime I log out.

Steps to Reproduce:
1. login
2. logout
3.
  
Actual results:

logout eventually occurs but gnome-panel is stuck preventing logging back in
properly.

Expected results:

gnome-panel dies when gnome-session dies.

Additional info:

I'll include some back traces but they look useless to me.

Comment 1 Thomas J. Baker 2006-02-23 21:07:20 UTC
Created attachment 125137 [details]
gdb attach b a a tb log

Comment 2 Thomas J. Baker 2006-02-23 21:09:05 UTC
make that gdb attach "t a a bt" log

Comment 3 Rahul Sundaram 2006-03-09 08:00:33 UTC

Unable to reproduce this here but if it is still present, this is a potential
blocker. 

Comment 4 Ismael Juma 2006-03-09 08:51:57 UTC
Isn't this related to bug #182957 and bug #184285 (which were fixed recently)?

Comment 5 Matthias Clasen 2006-03-09 17:24:14 UTC
I assume so. Thomas, are you still able to reproduce this with
gnome-applets-2.13.90-6 ?

Comment 6 Thomas J. Baker 2006-03-09 17:35:46 UTC
It does indeed seem to be fixed. I've logged out twice today with expected results.

Comment 7 Ray Strode [halfline] 2006-03-09 17:59:42 UTC
Great, let's close it.  If you see the problem again, please reopen.


Note You need to log in before you can comment on or make changes to this bug.