Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 182608 - incomplete power off using xen
Summary: incomplete power off using xen
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 5
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Juan Quintela
QA Contact:
Whiteboard: MassClosed
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
Reported: 2006-02-23 17:30 UTC by Alexandre Oliva
Modified: 2008-01-20 04:36 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2008-01-20 04:36:45 UTC

Attachments (Terms of Use)

Description Alexandre Oliva 2006-02-23 17:30:01 UTC
Description of problem:
My 3 old Athlon 1.4 boxes with Asus A7V133 MoBos have started failing to
poweroff in the past two days.  They'd power off fine with FC5T3, but after
installing 20060222 and 20060223 updates, always using the xen and kernel
available from the previous day's rawhide, the box wouldn't power off entirely.
 Although the leds on the case would switch off, the box kept on producing
noise, as some fan kept running.  I had to press the switch button for 5 seconds
to turn that off.

This problem does not happen if I boot into the non-xen kernel.

Version-Release number of selected component (if applicable):

How reproducible:
Every time

Steps to Reproduce:
1.Boot up into Xen
2.Run `poweroff´
Actual results:
The leds on the case say the box is powered off, but the fans keep running

Expected results:
What part of `power off' does it not understand? :-)

Additional info:

Comment 1 Alexandre Oliva 2006-02-23 17:51:25 UTC
I've just realized that, before installing the 20060221 updates, I was *not*
running the Xen kernel.  I'd modified grub to boot into the non-Xen kernel, but
I had not modified /etc/sysconfig/kernel, so when I updated the kernel, it
switched to the Xen kernel by default.  So this was not quite a Xen regression,
just a regular Xen bug.

Comment 2 Bill Jones 2006-03-10 19:28:40 UTC
This issue still exists with Hypervisor Kernel 1955 as well.

Comment 3 Leslie Satenstein 2006-03-11 13:58:37 UTC
I have a ambios with amd semptron (32bit), 756meg memory. Everything appears to
power down as shown by the screen displays, but when a halt is givcn, the
message I have is POWER OFF. It is provided twice. And then..... time to hit the

Comment 4 LarryT 2006-03-12 06:10:17 UTC
Have the same problem.
amd64 2.6. ddr 1.3go sata

Comment 5 LarryT 2006-03-12 06:16:51 UTC
resolved with Hypervisor Kernel 2041 :)

Comment 6 LarryT 2006-03-12 06:24:46 UTC
sorry : no Hypervisor Kernel 2041 !
i miss something :(

Comment 7 LarryT 2006-03-12 06:30:18 UTC
last Hypervisor is Kernel 2009, and the problem is not solved !

Comment 8 Leslie Satenstein 2006-03-19 11:37:06 UTC
Kernel 2041, both xen and non-xen manifest this problem. My System config is
listed in a preceding comment.

Comment 9 Stephen Tweedie 2006-03-20 15:09:13 UTC
Regarding comment #8 (from Leslie Satenstein):

Any bugs that are reproducible on both the xen and non-xen kernels are not
xen-specific, and really need to be opened in a separate bug report.  The
problem in this report is specifically that the xen kernel does not power down
where the normal kernel does.

2054-xen0 still doesn't power-off for me; can anyone else reproduce this as
fixed in 2041 or later?

Comment 10 Alexandre Oliva 2006-03-28 07:04:47 UTC
Not fixed for me with rawhide-20060327's xen and kernel-xen0.  It powers off
fine without Xen.

Comment 11 Dave Jones 2006-10-16 17:21:55 UTC
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.

Comment 12 Jon Stanley 2008-01-20 04:36:45 UTC
(this is a mass-close to kernel bugs in NEEDINFO state)

As indicated previously there has been no update on the progress of this bug
therefore I am closing it as INSUFFICIENT_DATA. Please re-open if the issue
still occurs for you and I will try to assist in its resolution. Thank you for
taking the time to report the initial bug.

If you believe that this bug was closed in error, please feel free to reopen
this bug.

Note You need to log in before you can comment on or make changes to this bug.