Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 182350 - pam_unix.so auth entry in system-auth should be created with try_first_pass
Summary: pam_unix.so auth entry in system-auth should be created with try_first_pass
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: authconfig
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2006-02-21 23:01 UTC by Jon Nettleton
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-03-03 14:06:36 UTC


Attachments (Terms of Use)

Description Jon Nettleton 2006-02-21 23:01:27 UTC
Description of problem:
/etc/pam.d/system-auth is creating the pam_unix.so entry without the
try_first_pass option.  With the deprecation of pam_stack module this is needed
so having prior optional auth modules don't require a password to be typed in twice.

Version-Release number of selected component (if applicable):


How reproducible:
everytime if you have an optional auth module before the include

Steps to Reproduce:
1.edit /etc/pam.d/gdm and edit it so it looks like this

auth       required     pam_env.so
auth       optional     pam_unix.so
auth       include      system-auth
2.sudo killall gdm-binary
3.logging in as yourself will now require you to type the password twice
  
Actual results:
You have to type the password twice

Expected results:
You should only have to type in a single password

Additional info:

Comment 1 Tomas Mraz 2006-03-03 14:06:36 UTC
Should be fixed in latest authconfig and pam packages.


Note You need to log in before you can comment on or make changes to this bug.