Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 182325 - getkeymaps errors in buildinstall on serial console
Summary: getkeymaps errors in buildinstall on serial console
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Peter Jones
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC7Target
TreeView+ depends on / blocked
 
Reported: 2006-02-21 20:52 UTC by Mike McLean
Modified: 2007-11-30 22:07 UTC (History)
4 users (show)

Fixed In Version: RHBA-2007-0215
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-01 17:19:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0215 normal SHIPPED_LIVE anaconda, and rhpl bug fix update 2007-05-01 17:16:50 UTC

Description Mike McLean 2006-02-21 20:52:15 UTC
On ia64 (and presumably i386/x86_64), buildinstall will spew errors about ioctls
failing if the system is on a serial console.

Example output:
Loading /lib/kbd/keymaps/i386/azerty/be-latin1.map.gz
ioctl failed: Invalid argument
Loading /lib/kbd/keymaps/i386/qwerty/br-abnt2.map.gz
ioctl failed: Invalid argument
Loading /lib/kbd/keymaps/i386/qwerty/cf.map.gz
ioctl failed: Invalid argument
...

Comment 6 RHEL Product and Program Management 2007-01-03 19:46:16 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 8 Peter Jones 2007-02-06 18:36:23 UTC
*** Bug 227148 has been marked as a duplicate of this bug. ***

Comment 9 Peter Jones 2007-02-06 18:38:09 UTC
Should be fixed in the next build.

Comment 10 Peter Jones 2007-02-06 18:59:22 UTC
That build is anaconda-10.1.1.58-1 .  Mikem said he'd do a test compose when the
build finishes, so we can make sure this issue is cleared up before the nightly run.

Comment 13 David Lawrence 2007-04-10 16:27:02 UTC
verified fixed in latest snapshots.

Comment 16 Red Hat Bugzilla 2007-05-01 17:19:15 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0215.html



Note You need to log in before you can comment on or make changes to this bug.