Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 182207 - (xen, nv) horiz line of corruption on top of screen
Summary: (xen, nv) horiz line of corruption on top of screen
Keywords:
Status: CLOSED DUPLICATE of bug 182578
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2006-02-20 23:58 UTC by Chris Kloiber
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-03-07 05:52:42 UTC


Attachments (Terms of Use)
xorg.conf (deleted)
2006-02-20 23:58 UTC, Chris Kloiber
no flags Details
Xorg.0.log (deleted)
2006-02-20 23:59 UTC, Chris Kloiber
no flags Details
Screenshot actually shows the corruption. (deleted)
2006-02-21 02:56 UTC, Chris Kloiber
no flags Details

Description Chris Kloiber 2006-02-20 23:58:32 UTC
Description of problem:

Running xorg-x11-server-Xorg-1.0.1-6.1 with nv driver on Geforce 6600 (PCI-e)
from Test3 trees and have experienced a single horizonal line of corrupted
pixels approximately 24 pixels from the top of the screen. You can "erase" the
corruption by moving a screen around over that area, but eventually it will come
back. There are some activities (can't tell which) where you can watch the
corruption occur. indeed this may not really be an X issue, but another
application overriting screen memory. There is nothing unusual logged, and no
problems running X. It seems most noticible right after login, or if you leave
the desktop sitting there a while.

Comment 1 Chris Kloiber 2006-02-20 23:58:32 UTC
Created attachment 124920 [details]
xorg.conf

Comment 2 Chris Kloiber 2006-02-20 23:59:44 UTC
Created attachment 124921 [details]
Xorg.0.log

Comment 3 Chris Kloiber 2006-02-21 02:56:27 UTC
Created attachment 124932 [details]
Screenshot actually shows the corruption.

This is what the corruption looks like some of the time.

Comment 4 Mike A. Harris 2006-03-07 01:47:09 UTC
Are you using Xen?

Comment 5 Mike A. Harris 2006-03-07 01:50:00 UTC
Ah yes, from the log:

Current Operating System: Linux borg.ckloiber.com 2.6.15-1.1955_FC5hypervisor #1 
SMP Wed Feb 15 16:02:06 EST 2006 x86_64


This problem happens on Radeon hardware using the "radeon" driver as well, and
is increasingly looking like a xen kernel bug.  It appears as if kernel console
messages get displayed to video memory still.


Comment 6 Chris Kloiber 2006-03-07 02:19:38 UTC
I was, yes. And you are right about the radeon driver too. This happens on my
x86_64/radeon m10 laptop as well when Xen is installed (right before the laptop
preforms an emergency thermal shutdown because there's no acpi/cpu scaling in
Xen, but that's another bad bug).

Will you be passing this to the kernel team then?

Comment 7 Mike A. Harris 2006-03-07 05:52:42 UTC
Yeah, I guess we can consider this a dupe of bug #182578



*** This bug has been marked as a duplicate of 182578 ***


Note You need to log in before you can comment on or make changes to this bug.