Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 182093 - Font packages have missing and incorrect PreReq dependencies
Summary: Font packages have missing and incorrect PreReq dependencies
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: XFree86
Version: 3.0
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks: RHEL3U8CanFix
TreeView+ depends on / blocked
 
Reported: 2006-02-20 14:20 UTC by Dag Wieers
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version: RHBA-2006-0410
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-07-20 15:25:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0410 normal SHIPPED_LIVE XFree86 bug fix update 2006-07-19 21:25:00 UTC

Description Dag Wieers 2006-02-20 14:20:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20060130 Red Hat/1.0.7-1.4.3 Firefox/1.0.7

Description of problem:
[root@lxtrpxy01 root]# rpm -e chkfontpath compat-db cpp curl desktop-file-utils switchdesk tcl ttmkfdir XFree86-100dpi-fonts XFree86 XFree86-75dpi-fonts XFree86-base-fonts XFree86-font-utils XFree86-Mesa-LibGLU Xfree86-tools XFree86-xfs xinitrc xterm
error: package XFree86-Mesa-LibGLU is not installed
error: package Xfree86-tools is not installed
error: Failed dependencies:
        XFree86 is needed by (installed) XFree86-tools-4.3.0-97.EL
[root@lxtrpxy01 root]# rpm -e chkfontpath compat-db cpp curl desktop-file-utils switchdesk tcl ttmkfdir XFree86-100dpi-fonts XFree86 XFree86-75dpi-fonts XFree86-base-fonts XFree86-font-utils XFree86-Mesa-LibGLU XFree86-tools XFree86-xfs xinitrc xterm
error: package XFree86-Mesa-LibGLU is not installed
/var/tmp/rpm-tmp.90935: line 3: /usr/X11R6/bin/mkfontdir: No such file or directory
error: %postun(XFree86-75dpi-fonts-4.3.0-97.EL) scriptlet failed, exit status 127
/var/tmp/rpm-tmp.31442: line 3: /usr/X11R6/bin/mkfontdir: No such file or directory
error: %postun(XFree86-100dpi-fonts-4.3.0-97.EL) scriptlet failed, exit status 127


Version-Release number of selected component (if applicable):
XFree86-4.3.0-97.EL

How reproducible:
Always

Steps to Reproduce:
1. Remove first mkfontdir and afterwards the XFRee86-75dpi-fonts
2.
3.
  

Actual Results:  Error

Expected Results:  Dependency check

Additional info:

Comment 1 Dag Wieers 2006-02-20 14:22:03 UTC
Apparently I paste too much. Please ignore the first command :-)

Comment 2 Mike A. Harris 2006-02-21 10:06:09 UTC
> Font packages do not require /usr/bin/mkfontdir

Nor should they, as that is included in modular X.Org X11 in FC5 only.
It is located in /usr/X11R6/bin/mkfontdir in XFree86 and monolithic
xorg-x11 packaging.

Comment 3 Mike A. Harris 2006-03-07 20:47:05 UTC
It appears the XFree86 4.3.0 packaging does not have proper rpm dependencies
listed for all of the %post/%postun scripts.  Also, it's currently using
PreReq in many places which should be updated to use Requires(pre),
Requires(post), etc.

In theory, PreReq is supposed to handle this, but it is possible it is not
working that way.  We should update the packaging to properly list deps
anyway.

If that doesn't fix it, it is possible there is a bug in rpm, as ISTR
something like that being reported before.

Comment 4 Mike A. Harris 2006-03-07 22:18:23 UTC
Er..  somehow accidentally got reassigned to rpm...  Reassigning back
to XFree86 component.

Comment 5 Mike A. Harris 2006-03-07 22:40:24 UTC
The XFree86.spec fix for this, will be replacing all of the "PreReq" entries
with
"Requires(post): ..."
"Requires(postun): ..."

Just in case someone else makes the change other than me, do not use the
shorthand syntax of "Requires(post,postun)" however because there are bugs
in rpm that will cause that to fail.

In addition to the font script dependency fixes for this, a complete scan
of all dependencies in the rpm should be performed and any legacy PreReq
entries should be updated to the Requires(foo) syntax.  Also, all rpm scripts
should be scanned for dependencies which may be missing from Requires(foo)
in the given subpackages, and new deps added as needed to prevent other
problems from occuring of this nature.

Additionally, the RHEL-4, FC-4 xorg-x11 packaging should be reviewed to
ensure that the same problems are fixed in those releases if present.  If
problems are discovered in those releases, new bugs should be filed to track
the issue in each OS release as appropriate.


Comment 10 Mike A. Harris 2006-04-25 03:13:55 UTC
Fixes for RHEL-3 checked into CVS for package build 102.EL and later.

Will update bug with test packages once package is built.

Comment 11 Mike A. Harris 2006-04-25 13:38:46 UTC
XFree86-4.3.0-102.EL is now available for download via ftp
at the following URL:  ftp://people.redhat.com/mharris/testing/3.0E

After upgrading all of the packages, please test them to see if the problem
reported has now been resolved and not any changes (good/bad).



Comment 12 Mike A. Harris 2006-05-04 10:49:33 UTC
XFree86-4.3.0-104.EL is now available for download via ftp at the following URL:
 ftp://people.redhat.com/mharris/testing/3.0E

Comment 16 Red Hat Bugzilla 2006-07-20 15:25:36 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0410.html



Note You need to log in before you can comment on or make changes to this bug.